It's all about the answers!

Ask a question

BMS Map - Copybook generation abend

Scott Pecnik (1336) | asked Jan 19 '13, 8:57 p.m.
 Hi All,

I'm trying to setup a test environment with RTC 4.0 Enterprise Edition and RD&T.  I'm using the sample application distributed by the wiki ( with no additional changes.    

Right now i'm just trying to get an Ant EE build to complete, but am having an issue with the copybook generation step of the BMS maps.  The peculiar part is that RTC seems to abend before i'm able to get any helpful logging info.  In other words, I get an OC1 as if a module was not found, but when I try to add a SYSUDUMP card to the translator, I get no output as the abend occurs before the SYSUDUMP.  The same happens for SYSPRINT.  Without any way to bring back this information, i'm at a loss for what could be going wrong.

In order to rule out my ASMA90 compiler, I wrote a sample BMS Map and generated COBOL via a simple JCL, which worked without problems.

Anybody have an idea what could be wrong or have seem a similar issue?


Millard Ellingsworth commented Jan 23 '13, 5:44 p.m.

Hi, Scott. Sorry you are having problems with this. The referenced article has a link to another: Build environment setup for mortgage sample application. Did you follow all the steps there?

I'm also checking with the author as the newer of those articles is over 2 years old and may not have been tested with RTC 4.0.

Scott Pecnik commented Jan 23 '13, 6:07 p.m.

Hi Millard.  Thanks for following up.  I believe I followed all of the steps correctly, with the exception being that I'm using a standard Ant EE build, not a dependency based build.

I'm thinking it may be system related, but there is no way for me to tell as the abend occurs before RTC can grab the SYSUDUMP or SYSPRINT.  I don't think it's an OOM as the Region size on the startup proc is set to 0M (and I think that would be reported back to me), but I'm wondering what size JVM the forked processes get.  Without any type of logging, it's almost impossible for me to debug.


2 answers

permanent link
Tami Takamiya (2011110) | answered Jan 25 '13, 9:32 a.m.

If you are using the sample project without modifications, temporary data sets are allocated to VIO.  Would you try to change all string "VIO" to "SYSDA" in the setuprtcz.xml setup script and configure the environment with the modified script?  We had a similar issue before (in our case it was S0C4 abend instead of S0C1) and it was resolved by replacing "VIO" to "SYSDA".

Tami (Masaaki) Takamiya

Scott Pecnik commented Jan 28 '13, 1:25 p.m.

Hey Tami,

Great to hear from you!  I tried changing the temporary data set definitions to go to SYSDA and even SYSALLDA, still no luck and am getting the OC1.  LIke I said above, I can do a BMS MapGen via standard JCL, for some reason the abend is occuring in RTC and it's happening before even the SYSPRINT is created.


permanent link
Tami Takamiya (2011110) | answered Jan 28 '13, 2:39 p.m.
I have no good idea on what's going on...

In the build log, you can see the output of  'ulimit -a' command like:

* core file         8192b
* cpu time          unlimited
* data size         unlimited
* file size         unlimited
* stack size        unlimited
* file descriptors  64000
* address space     unlimited
* memory above bar  17592186040320m

Is the address space of your build environment also set to 'unlimited'?

Tami (Masaaki) Takamiya

Scott Pecnik commented Jan 28 '13, 6:59 p.m.

Tami, this is what I am showing on my system.  I thought that these values would be sufficient.

 * OS/390 ADCD113 23.00 03 1090
* core file         8192b
* cpu time          unlimited 
* data size         unlimited 
* file size         unlimited 
* stack size        unlimited 
* file descriptors  64000 
* address space     1614824k
* memory above bar  17592186040320m

Tami Takamiya commented Jan 28 '13, 7:39 p.m.

Ok... Did any compilation work in your setup before?  Or is this the first attempt?  I think the BMS Copybook generation is the very first translator call.

Tami (Masaaki) Takamiya

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.