It's all about the answers!

Ask a question

keep getting error: CRRTC3503E: Invalid arguments used for authentication


Egidijus Milierius (122) | asked Jan 07 '13, 10:39 a.m.
edited Jan 07 '13, 10:40 a.m.
Hello,

Whenever I specify userId with pass or passwordFile I keep getting the same error.

BuildToolkit 3.0.1. extracted from a zip file on a linux.

Any help would be appreciated. Thank you.


2 answers



permanent link
Lauren Hayward Schaefer (3.3k11427) | answered Jan 08 '13, 7:22 a.m.
JAZZ DEVELOPER
Can you include the command you're using to start up the build engine?  For example, I'm able to start my build engine by using the following params :
-repository https://myserver:9443/jazz/ -userId myuserid -pass mypassword -engineId "Lauren's Build Engine"

or by using a password file:

-repository https://myserver:9443/jazz/ -userId myuserid -passwordFile C:/rtc40/toolkit/jazz/buildsystem/buildengine/eclipse/pass.file -engineId "lauren.build.engine"

Comments
Egidijus Milierius commented Jan 08 '13, 7:49 a.m.

Thank you for your answer.
I am using version BuildToolkit 3.0 as my RTC server is 3.0.1. My userId has build permissions in RTC server.

I am using zip version for linux: https://jazz.net/downloads/rational-team-concert/releases/3.0/RTC-BuildSystem-Toolkit-Linux-3.0.zip

Download site: https://jazz.net/downloads/rational-team-concert/releases/3.0?p=allDownloads

I was trying -passwordFile parameter too. The file was created like this: jbe -createPasswordFile conf/buildPassword.txt . I got the same error as below.

StackTrace:
[server]$ ./jbe -repository https://server1:9443/jazz/ -userId myUser –pass myPassword -engineId engine1

CRRTC3503E: Invalid arguments used for authentication. Specify one of the following combinations (-userId and [-pass or -passwordFile])] or (-certificateFile and [-pass or -passwordFile]) or (-smartCard and -userId)

<...>

CRRTC3529I: Completed JBE execution, RC=1.


Lauren Hayward Schaefer commented Jan 08 '13, 8:03 a.m.
JAZZ DEVELOPER

Quick question just to be sure....  It looks like your dash before "pass" is longer than your other dashes.  Can you double check you're using the regular single dash?  (I know sometimes Microsoft Word will lengthen dashes, which makes them a different character.)


permanent link
Egidijus Milierius (122) | answered Jan 08 '13, 8:51 a.m.
Resolved :)

My username was with invalid encoding because on copy/paste. Typed in my username and it worked!

Thank you,

Comments
Lauren Hayward Schaefer commented Jan 08 '13, 9:02 a.m.
JAZZ DEVELOPER

Glad you got it working!

Your answer


Register or to post your answer.