It's all about the answers!

Ask a question

Time Spent when choosing minutes shows percentages on certain values


John S F Lander (901737) | asked Jan 04 '13, 10:12 a.m.
Time Spent of type duration
on editor presentation of Kind = Time Spent

When entering minutes
Value 3           Shows 3 minutes
          4                       4 minutes 1.2 seconds
          5                       4 minutes 58.8 seconds
          6                       6 minutes
and so on

i just want to show minutes and integers ?

Reason is using RTC for support calls aswell where turnaround can be quite small

Comments
Millard Ellingsworth commented Jan 04 '13, 1:25 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

Are you using Scrum template and tracking progress as Time Spent or adding a custom duration field and setting its presentation to Time Spent?


John S F Lander commented Jan 07 '13, 5:35 a.m.

Athough originally the PA was created with the Scrum template, this PA has been heavily customised, but is using editor "com.ibm.team.workitem.editor.default" and the attribute "Time Spent" id=com.ibm.team.workitem.attribute.timespent of type Duration
Regards
John


Millard Ellingsworth commented Jan 07 '13, 1:55 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

In your Planning configuration, how is progress tracked: As Time Spent or Time Remaining? Are you just trying to use minutes in the default Time Spent presentation? Which version of RTC? We'll track this down and either find or file a defect as needed.


John S F Lander commented Jan 07 '13, 2:15 p.m.

Time Spent.
Minutes would be fine as some PAs are using to capture all their Support calls which are quite small in duration.
We then want to use RRDI to start producing stats around average turn around time etc


Millard Ellingsworth commented Jan 08 '13, 4:43 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

I probably should have started with this step: Anything in particular you can suggest about reproducing the issue? I can't find any related defects and I just created simple scrum templates in both 3.0.1.x and 4.0.1 and I don't see the behavior you describe. What version of RTC is used (client and server) and have there been any customizations that would affect time spent?


John S F Lander commented Jan 09 '13, 9:46 a.m. | edited Jan 09 '13, 9:50 a.m.

Both the Web and client 3.0.1.1

Raising with 5 m

mins and secs Attribute
When i put 5 mins in the eclipse client and then show on the Web , it does not convert to mins and secs but stays as 5 m


John S F Lander commented Jan 16 '13, 7:28 a.m.

Thanks - I will start to work through this.
Is there anyway we can set the default to minutes and not hours


Millard Ellingsworth commented Jan 16 '13, 11:51 a.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

I am not aware of a way to change the default units. There is an Enhancement request around duration fields in general: https://jazz.net/jazz/web/projects/Rational%20Team%20Concert#action=com.ibm.team.workitem.viewWorkItem&id=171455


You are welcome/encouraged to add your requirements to this so they are part of the larger discussion around improvements in this area. 

showing 5 of 8 show 3 more comments

One answer



permanent link
Millard Ellingsworth (2.5k12431) | answered Jan 09 '13, 3:03 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER
Using 3.0.1.4 I cannot recreate this using an OOTB scrum template and changing it to track Time Spent (nor in 4.0.1). Five minutes always displays as "5 minutes" no matter where I enter it, how many times I change it nor how often I refresh the page. Do you have a sandbox where you can create a project form your customized template and test with a more recent version of RTC? Unless we can recreate in a current code line and track it to a defect in the product I think your fix will be to upgrade.

Your answer


Register or to post your answer.