It's all about the answers!

Ask a question

Save conflict. Failed saving work item because it didn't have the most recent state.


Paula Izaurralde (6122428) | asked Jan 02 '13, 1:37 p.m.
I have a work item (user story) that has one child (task). This task also has children (more tasks).
For some reason I cannot save any changes I make to the sub tasks. The message says that I don't have the most recent state. But I refresh and then try again, and get the same error.

Comments
Karl Weinert commented Jan 03 '13, 8:06 a.m.
JAZZ DEVELOPER

Paula,
Please reproduce the problem a few times and check the JTS and CCM logs for any errors that consistently show up at the same time as you see the error message.

I found a defect that was opened from a PMR where the customer was getting a similar error:
https://jazz.net/jazz/web/projects/Jazz%20Foundation#action=com.ibm.team.workitem.viewWorkItem&id=191577




Millard Ellingsworth commented Jan 03 '13, 6:17 p.m.
FORUM ADMINISTRATOR / JAZZ DEVELOPER

Hi, Paula. 

Would you please provide some more details? What version of RTC? What process template? Do you have any process customizations? Are all of the items owned by same team/on same plan?

I did this (in RTC 4.0.1): created a Story with a Master task and 2 subtasks. I opened all of them and the plan they live on in different tabs. I was able to update any of the items without conflicts.  Was able to force conflicts (and get the save error) but a refresh always cleared the error and allowed me to keep making changes.


Fred Atwater commented Jan 24 '13, 4:04 p.m.

So you get the conflict error when you try to save. Is there any way to know an item is being edited by someone else before you make all your changes?


Geoffrey Clemm commented Jan 26 '13, 2:55 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

You can detect that someone has made changes to an item you are editing (the GUI will generate a warning when that is detected), but there is currently no way for the server to know that someone is intending on editing the item before they have actually posted those changes to the server.


Stuart Cornell commented Mar 01 '13, 11:13 a.m.

 I am seeing the exact same issue Paula describes. However I have no idea what ETLs are or whether they are running on our system. I am using 4.0.1 and have a set of Tasks which cannot edit at all. I have tried logging out and in, and there is no chance that anyone else is updating these entries. I suspect the issue is related to predecessor links which I was editing that got mixed up.

Any advice? I would happily delete them if I could.

One answer



permanent link
Paula Izaurralde (6122428) | answered Jan 11 '13, 10:01 a.m.
Thanks all for you help!,
The problem was because of the ETLs were not working.
Now that the ETLs are running again, the issue with the work item was fixed.
Thanks

Your answer


Register or to post your answer.