It's all about the answers!

Ask a question

Issues with build engines in Eclipse.

Enrico Paolo Lelli (524) | asked Feb 18 '13, 11:25 a.m.
Hi all,
I'm trying to set up a continuous integration environment with RTC-Jazz-Eclipse but I'm failing somewhere and I broke the wall where I'm banging my head so...decided to look out for help :D
I'm pretty new to this topic so I might easily have missed some simple step but can't see it.
I'll describe what am I doing and hopefully someone will spot the error.
In Eclipse, in Team Artifatcs view I right click on Build and select New Build Definition.
I select the Team Area interested and Create a new build. I set ID= "SFC-CI definition" and as build template Command "Line - Jazz Build Engine", select the "Jazz Build Control" check and then finish.
When the build definition opens I click on Create under Suporting Build Engines, I set ID= "SFC-CI engine" and "Jazz Build Engine" as engine type.

So I have the following definition overview:
Definition overview

The following definition JSC: Definition Jazz Source Control

The following definition command line:
definition command line

And the  I have the following Engine where I have the problem you can see:

Whenever I try to request a build like this it remains pending.
build request

I tried to read in different forums about the warning in the build engine but what I understood is that it's linked to the Jazz server which should be running and is not. But then I read that using Eclipse this should be automatically invoked... to be honest I'm totally confused.

Could you please help me out and make me understand what's going on? I obviously lack some theory here but can't find anywhere a "build engines for dummies" XD


Accepted answer

permanent link
Ralph Schoon (63.3k33646) | answered Feb 18 '13, 12:36 p.m.
edited Feb 18 '13, 12:39 p.m.
Apparently there is no Jazz Build Engine running anywhere.

In order for this to work, you have to install the Jazz Build System Toolkit on some machine. Once it is installed, you need to start a build process for that engine Id. You run the jbe.exe in the buildsystem/buildengine/eclipse folder and provide parameters.

For example:

jbe.exe -repository -userId build -pass build -engineId -sleepTime 3

The engine ID must be the ID you defined. The user must be a real user, part of the project to be able to access the SCM data and should have a Build System License assigned. If you build against anything, it needs to be accessible for the build user. It can't be a private repository workspace for example. The Build definition should use a repository workspace that flows against the stream you want and the build user should be its owner.
Enrico Paolo Lelli selected this answer as the correct answer

Enrico Paolo Lelli commented Feb 20 '13, 6:14 a.m.

Thank very much Ralph, I was a bit confused about this toolkit cause I thought it was a stand alone part, not to be used with Eclipse.
That solved my problems. 

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.