It's all about the answers!

Ask a question

What the message "The system cannot execute the specified program" mean when running the jsl -debug command?


Ziv Rechnitser (911618) | asked Dec 24 '12, 4:26 a.m.
edited Dec 24 '12, 5:43 a.m.
 Hi All,

I trying to run the JBE as windows service, I use the instructions  like in this guide: https://jazz.net/wiki/bin/view/Main/JbeAsAWindowsService.
It's not the first time I do so, in all the other times it's worked fine.
This time, when I run the jsl -debug command I get this message:
"The system cannot execute the specified program".
Anyone know what this message mean? and if so, what to do?

Thanks,

Ziv

Comments
Karl Weinert commented Dec 24 '12, 9:34 a.m.
JAZZ DEVELOPER

Anything useful in the jsl.log file? It should get created in the same directory as the jsl.exe
It could be some missing windows libraries. You can check with dependency walker http://www.dependencywalker.com/
I often see missing dll errors and such with programs that work just fine so it isn't a guarantee to be the problem. I tested here and only  see a problem with one dll on  my windows 7 system (IESHIMS.DLL)
What version of windows? Are you using the 32 or 64 bit version of jsl?


Ziv Rechnitser commented Dec 25 '12, 2:03 a.m.
Hi Karl,
Thanks for the answer.
I don't see any log file in the jsl folder.
We use windows server 2003 r2 32 bit.
I used the "Dependency" app on the jsl.exe and I can see that there is two missing dll files: MSVCR90.dll & MSJAVA.dll.
I ran a search on the server and I couldn't found those files.
Any ideas what can We do to solve this issue?
 

2 answers



permanent link
Arne Bister (2.6k12732) | answered Dec 24 '12, 6:57 a.m.
JAZZ DEVELOPER
Hi,

this is a duplicate of another forum question. Although there is no accepted answer in the other entry, there are three suggestions in the last comment. Does one of them work for you?

- Arne

Comments
Ziv Rechnitser commented Dec 24 '12, 7:13 a.m.

Hi, 


Yes, I was tried to use the answers in the other post but none of them don't helped.


Ziv Rechnitser commented Dec 27 '12, 4:32 a.m.
Hi, 
After a few attempts I  decided to reinstall the OS to server 2008 r2.
After  i did it, I Succeeded to use the jsl64 -debug and the jsl64 -install commands.
Now I have a new problem, when I start the service there is error message that say: "Error 1053: the service did not respond to the start or control request in a timely fashion".
The process jsl64.exe is ran and when I request a build its works fine.

What can be the reason that cause the service to fail? 


Karl Weinert commented Dec 27 '12, 8:10 a.m.
JAZZ DEVELOPER

Not sure of the cause of this current issue. But I read another post that it is much easier to run the build engines via the Task Scheduler on Windows 2008.


Ziv Rechnitser commented Dec 27 '12, 8:33 a.m.

I will check that, thanks.  


permanent link
Karl Weinert (2.0k52736) | answered Dec 27 '12, 9:42 a.m.
JAZZ DEVELOPER
Just to follow up in case anyone runs into the original issue.

I was able to reproduce "The system cannot execute the specified program" error on windows 2003 with the latest version of JSL (JSL 0.99n)

I resolved or worked around the issue by downloading an older version from the "Change log and archive" link. I chose JSL 99e because it specifically mentioned that it was Tested with Windows Server 2003

I didn't go any further than simply running jsl.exe -debug but it ran showing the output I would expect to see.


Your answer


Register or to post your answer.