It's all about the answers!

Ask a question

How to install RTC client on top of Eclipse ?

Eliya Voldman (41142) | asked Jun 05 '13, 3:03 p.m.


I'm using Open Client RHat 6.4 on my laptop. I was using RTC as a standalone program before with no issues. Now I wanted to install RTC on top of the existing eclipse but it failed all the time. I tried various combinations of eclipse editions and RTC but it always fails ( I am using Installation Manager ) on a page when it checks for plug-in dependencies. I tried to install those plug-ins using local or remote ... but it always failed. In my case I'd like to have RTC 4.0.3.

My question: does anyone have success to install RTC on top of eclipse on Open Client? If someone succeeded ... could you point me to release of eclipse you used or some other tricks you did for it?

P.S. I found this topic which states that it should work. I followed all the steps i.e. installed eclipse 4.3.0 , downloaded but the problem now is with installing that .zip. I've got the error:


!SUBENTRY 1 org.eclipse.equinox.p2.transport.ecf 4 1002 2013-06-05 13:58:57.100!MESSAGE Unable to read repository at jar:file:/home/evoldman/Downloads/!/content.xml.!STACK error in opening zip file        at Method)        at<init>(Unknown Source)        at<init>(Unknown Source)        at java.util.jar.JarFile.<init>(Unknown Source)        at java.util.jar.JarFile.<init>(Unknown Source)        at<init>(Unknown Source)        at Source)        at Source)        at Source)        at Source)        at org.eclipse.ecf.provider.filetransfer.browse.URLFileSystemBrowser.runRequest(        at org.eclipse.ecf.provider.filetransfer.browse.AbstractFileSystemBrowser$        at!ENTRY org.eclipse.equinox.p2.core 4 0 2013-06-05 14:00:48.245!MESSAGE Provisioning exception

Do you have any clue how to fix that ZipException thing?


Piotr Aniola commented Jun 05 '13, 3:15 p.m.
Which version of Eclipse are you using?

Eliya Voldman commented Jun 05 '13, 3:26 p.m.
Eclipse SDK
Version: 4.3.0
Build id: I20130530-1430

Bo Chulindra commented Jun 05 '13, 3:34 p.m.
Just fyi, I used P2 to install RTC 4.0.3 into my Eclipse 4.2.2 successfully but this is on Windows.

Eliya Voldman commented Jun 05 '13, 3:37 p.m.
Thanks for reply. At this point I didn't get to the problem of compatibility yet but the current problem is with my Open Client issue with

Eliya Voldman commented Jun 05 '13, 9:43 p.m.
Well ... I just thought that .zip file might be corrupted though I downloaded it from
I tried to unzip it and got this error:
[evoldman@voldman-lnx TBD]$ unzip
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of or, and cannot find, period.
[evoldman@voldman-lnx TBD
Any suggestions?

4 answers

Dinesh Kumar (3.2k313) | answered Jun 06 '13, 4:28 a.m.
just to be sure the download is completing, I always make use of a download manager, some tips to successful downloads are available here :

Dinesh Kumar commented Jun 06 '13, 5:35 a.m.
If you suspect the download is corrupt, you can verify using MD5 Verification. The detailed instructions are displayed when you selecting "Show MD5 download verification" from the "All Downloads" page.

In Summary, to verify the integrity of your Rational Team Concert downloads, compare
the MD5 cryptographic hash value for each downloaded file
the value provided in the counterpart .md5 file.

If the two hash values are identical, the Rational Team Concert download is good.

Piotr Aniola (3.5k631) | answered Jun 06 '13, 8:40 a.m.
edited Jun 06 '13, 8:41 a.m.
Please note that Eclipse 4.3 is not supported:

Tim Mok commented Jun 06 '13, 9:11 a.m.
I've installed into non-supported versions of Eclipse, including 4.3, using p2 so the install should work. However, it is a good thing to point out that Eclipse 4.3 isn't supported. There isn't much, if any, testing done on Eclipse 4.3 so there may be issues.

For a supported version, I'd recommend looking at the RTC 4.0.3 IM install for Eclipse 4.2 in the all downloads section.

Karl Weinert (2.0k3835) | answered Jun 06 '13, 9:44 a.m.
Try unzipping the file then when you add new repository choose local and point to the directory that contains the contents.xml file.

Eliya Voldman (41142) | answered Jun 06 '13, 10:42 a.m.

hi Folks,

thanks everyone for help and advices. Finally I'm all set. Eventually my problem was with corrupted p2 RTC-Client file. I installed Download Manager, downloaded .zip using it and was able to install RTC 4.0.3 on top of Eclipse 4.3

I acknowledge that this combination might be not tested and/or supported but for my needs it works fine.

thanks again.

Your answer

Register or to post your answer.