It's all about the answers!

Ask a question

Installation manager cannot connect to zip repository file


Bruno Di Giandomenico (50814) | asked Dec 04 '12, 4:14 a.m.
I have browsed through the forum but the answer does not seem to be existing, even though similar questions have been asked before, therefore I shall try again.
I have a problem because I have an RTC installation (4.0.1) in isolation; I have downloaded the client .zip repository files, but Installation Manager 1.6.0 keeps telling me that it cannot connect to the repository, that either the net is down or there is some problem with the firewall.

I can apparently open the .zip file, but I cannot fathom what is wrong (if anything is).

What am I doing wrong ? There must be an easy answer I am overlooking.
THanks to those who can help me out.

Bruno

Accepted answer


permanent link
Karl Weinert (2.0k42536) | answered Dec 04 '12, 10:11 a.m.
JAZZ DEVELOPER
edited Dec 04 '12, 10:32 a.m.
I had never tried pointing directly to the zip file but I see the same error as you when I did this time.

Here's the steps I used:
1. Unzip the zip file to a location that is accessible to the users that want to install it.
2. Open Installation manager and go to file-> preferences
3. Highlight Repositories and select Add Repository
4. Put in the path to the location of the directory that contains the repository.config file
This is the path for the Windows Shell Repo
...RTC-Windows-Shell-repo-4.0.1\im\repo\rtc-windows-explorer-offering\offering-repo


A little more info after playing around.
If you want to use a zip file the repository.config file needs to be in the root directory.
For example I created a zip file from the contents of RTC-Windows-Shell-repo-4.0.1\im\repo\rtc-windows-explorer-offering\offering-repo and I was able to point to that  zip file as a repository.

The same steps apply to the eclipse client repo as well
( RTC-Eclipse-Client-repo-4.0.1\im\repo\rtc-client-offering\offering-repo\)

Note Make sure there aren't two offering-repo directories in the zip file.
i.e. The zip extracts to  offering-repo\offering-repo\repository.config when it should just extract to offering-repo\repository.config
This happened when I right clicked the offering-repo directory and made the zip file from there.
Instead I had to  cd into ofering-repo and select all files then make the zip file.

Bruno Di Giandomenico selected this answer as the correct answer

Comments
Bruno Di Giandomenico commented Dec 05 '12, 3:01 a.m.

Thanks for your effort. That explains why the server zip file worked and the others did not.

3 other answers



permanent link
Jared Russell (1.3k12019) | answered Dec 04 '12, 4:58 a.m.
By default installation manager tries to connect to the net to check for updates etc for your packages. To disable this go to File -> Preferences -> Repositories and then uncheck the "Search service repositories during installation and updates." checkbox.


Comments
Bruno Di Giandomenico commented Dec 04 '12, 7:47 a.m.

I have tried but it does not work.
After all I have succeded in installing the RTC server via IM, and IM has accepted the related .zip file as repository. It does not understand the client though. My thoughts about this are that either the file is somehow corrupt (but I have downloaded 3 times the Dorrs next client, as a test, as it is very small) always with the same result, or that I do something wrong. Are the correct files to be used with IM the ones finishing in -repo.zip (e.g RTC-Windows-Shell-repo-4.0.1.zip) ? This could be the mistake I am doing too.


permanent link
Rosa Naranjo (2.8k11420) | answered Dec 04 '12, 10:44 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
Hello
What Karl explains above is the correct process for using an IM repo downloaded as a zip.  The zip file, for example, DNG-Rich-Client-Installer-4.0.1.zip, must be unzipped.  Then, you must follow the process outlined above to locate the repository.config file for this repository.  See that attached image.  I did this for the Doors Next Gen Client and it worked just fine.

If you are looking for the IM repo for the RTC Eclipse Client IDE, the correct file is called, https://jazz.net/downloads/rational-team-concert/releases/4.0.1/RTC-Eclipse-Client-repo-4.0.1.zip InstallingFromAZip

Comments
Bruno Di Giandomenico commented Dec 04 '12, 11:53 a.m. | edited Dec 04 '12, 11:54 a.m.

Thank you for the answer. I have no time for trying this solution tonight, I shall try tomorrow and let you know.
What led me astray was the fact that I was easily able to perform the installation of the RTC server just by pointing at the zip file as repository, so seeing two different behaviuors confused me.
I'll let you know.

Bruno


Karl Weinert commented Dec 04 '12, 12:02 p.m.
JAZZ DEVELOPER

The server download is set up correctly to use the zip file as the repository. There does not seem to be any reason for the extra directories in the eclipse client or the Windows Shell client. It might be worth opening an Enhancment request to have them all packaged that way.  https://jazz.net/jazz/web/projects/Rational%20Team%20Concert#action=com.ibm.team.workitem.viewWelcome


Bruno Di Giandomenico commented Dec 05 '12, 3:01 a.m.

Thank you all for the effort you put in answering, it all worked out.


permanent link
Bruno Di Giandomenico (50814) | answered Dec 05 '12, 3:00 a.m.
THanks everybody, it worked once I unpacked it all.
The reason I am using the zip file is because the installation is on a private internal network not connected to internet.
Thanks for the suggestions.
Now we have to migrate what we had in RC 3.0.1, but that is another story.

Your answer


Register or to post your answer.