It's all about the answers!

Ask a question

Unable to set values for enumeration attributes in RRC 4.0.1 M3


Samanwita Majumdar (5033639) | asked Oct 11 '12, 3:25 a.m.
I am trying to set values for enumeration data attributes using OSLC.
There is no error and at the same time no value is populated.

Using the following code to do the same

String access = findPropertyByTitle(doc, "Artifact Usage");

I get the correct URI for this attrbute . This is an enumerated attribute having key as Integer and Value as String

Tried the following to set

req.addRMIntegerProperty(access, 0);

Have also tried with the value corresponding to the key.
req.addRMIntegerProperty(access, "Work Product");

None of them work although the requirement URL looks good.

I get the attribute definition as follows:
<rm_property:_G4QYIQ7-EeKaDcaAOPjzYg rdf:datatype="http://www.w3.org/2001/XMLSchema#integer">0</rm_property:_G4QYIQ7-EeKaDcaAOPjzYg>

Is there any idea whats the error?

Thanks,
Samanwita

2 answers



permanent link
Gabriel Ruelas (1.1k13) | answered Oct 11 '12, 10:30 a.m.
I tested a similar example using the HTTP Requester and seems to be working fine ( The int value is properly changed ). I suggest to try first changing the value using a Poster tool ( like HTTP Requester ) and once you get the right body that allows the change move that to the code.

Comments
Preetam Sikdar commented Oct 12 '12, 1:45 a.m.

Hi Gabriel,
Can you please guide us to some examples/documents/codes on the above topic


permanent link
Gabriel Ruelas (1.1k13) | answered Oct 16 '12, 12:05 p.m.
The OSLC Workshop does contains the source code for the basic OSLC functionality.

https://jazz.net/library/article/635


Your answer


Register or to post your answer.