It's all about the answers!

Ask a question

CRJAZ1316I on workitem with RTC 3.0.1.3


Bill Glidden (1111) | asked Oct 09 '12, 2:27 p.m.
 I will start by confessing my complete newbie status to RTC and using the web services API...

I have a python program which is able to successfully create a work item. I can go into the RTC and see the work item just fine, and see that it has most of the fields I tried to populate. However, if I then try to query the work item using the web services, I get the CRJAZ1316I error. I saw some other posters were told that upgrading to 3.0.1.1 would be a good start, but we're already at 3.0.1.3 ... this used to work for me so I'm lost as to why now it wouldn't.


Any suggestions would be appreciated!

Comments
Bo Chulindra commented Oct 16 '12, 3:42 p.m.
JAZZ DEVELOPER

Just to put this out there:

CRJAZ1316I Illegal read access:  User "{0}" attempted to read item(s) having the following type(s): {1}

3 answers



permanent link
Lauren Hayward Schaefer (3.3k11227) | answered Oct 10 '12, 7:26 a.m.
JAZZ DEVELOPER
Hi Bill,
This is a pure guess -- It seems that the error you're hitting is related to permissions.  You said that what you're doing used to work for you, but now it doesn't.  Are you using licenses that have recently expired?

permanent link
Bill Glidden (1111) | answered Oct 10 '12, 9:06 a.m.
I don't think this is related to permissions or licenses since I can access the created work item just fine through the RTC web interface or the Eclipse front-end.

permanent link
Karen Steele (1.1k1127102) | answered Nov 30 '12, 4:10 p.m.
I have a similar issue on a single work item that is reporting the same and I have full work item permissions across the board including JazzUser and JazzPrjAdmin repository permissions ... it is not permissions even though it says it is ... any ideas ?

Your answer


Register or to post your answer.