It's all about the answers!

Ask a question

Urgent: Problem with Installation Manager for RTC


Girish Rao (111) | asked Sep 04 '12, 1:53 a.m.

Hello Jazz Team,

  I was upgrading from RTC 2.0.0.2 to RTC 3.0.1.2. While doing this I realised that my IM also needs to be upgraded. I currently have Ver 1.3.2 and using that I cannot upgrade the newer RTC Versions. I tried to uninstall my IM but it said the associated installed components need to be un-installed first. So, I tried un-installing my RTC. But that ran into an error, after which my IM uninstall is also failing. Every time I try to run the un-install it creates a log file. The contents I'm attaching below. Now I'm really lost as to what needs to be done to get rid of this issue. Any help is appreciated.

!SESSION 2012-09-03 19:36:37.218 -----------------------------------------------
eclipse.buildId=unknown
java.fullversion=J2RE 1.5.0 IBM J9 2.3 Windows XP x86-32 j9vmwi3223ifx-20080811 (JIT enabled)
J9VM - 20080809_21892_lHdSMr
JIT  - 20080620_1845_r8
GC   - 200806_19
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments:  -accessRights admin
Command-line arguments:  -os win32 -ws win32 -arch x86 -accessRights admin

!ENTRY org.eclipse.osgi 4 0 2012-09-03 19:36:37.796
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
 at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)
 at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
 at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:79)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
 at java.lang.reflect.Method.invoke(Method.java:618)
 at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
 at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
 at org.eclipse.equinox.launcher.Main.run(Main.java:1311)

3 answers



permanent link
Sonali Lekurwale (111) | answered Sep 04 '12, 2:10 a.m.
When you want to install new version of IM, you need not remove the earlier IM version.
Like other IBM Rational Products, IM automatically upgrades the previous version during installation.
So directly run the IM install application. It will upgrade the existing one to newer version.

Installed location would be identical for e.g. "C:\Program Files\IBM\Installation Manager\eclipse"
and its data location would also be identical for e.g. "C:\Program Files\IBM\Installation Manager"

Post, if any issues

Comments
Girish Rao commented Sep 04 '12, 2:45 a.m.

Hello, Tried installing IM 1.4.3 , but get the below error.

Error during "install" phase: Failed to create executable extension com.ibm.cic.agent.internal.adapters.nativeAdapter.win32.WinPlatformOperationsProvider: org.eclipse.core.runtime.CoreException: Plug-in "com.ibm.cic.agent.core.nativeInstallAdapter.win32" was unable to instantiate class "com.ibm.cic.agent.internal.adapters.nativeAdapter.win32.WinPlatformOperationsProvider".


permanent link
Sonali Lekurwale (111) | answered Sep 04 '12, 2:58 a.m.
It seems like the path to your installation files is too long.
So move the installation files to C:\Tmp. Create this 'Tmp' directory at top most level of C: Drive  such that it contains no space.
Also make sure you have local admin rights.

P.S. the latest IM available on Jazz.net is v 1.5.2.
Here's the download link:
https://jazz.net/downloads/ibm-installation-manager/releases/1.5.2.
Download and extract to above directory.


Comments
Girish Rao commented Sep 04 '12, 4:45 a.m.

Not sure I understand your answer about the creation of the C:\Tmp directory. What I noticed is that for extraction of the code it uses the default C:\Document & Settings\Administrator\Local Settings and for data install "C:\Program Files\IBM\Installation Manager". Don't know if your alluding to these directories in the note?


Girish Rao commented Sep 04 '12, 6:28 a.m.

Hello, I tried to create a C:\Temp Directory to hold the installation file for IM Ver 1.5.0. However I still get the below error.

Error during "install" phase: Failed to create executable extension com.ibm.cic.agent.internal.adapters.nativeAdapter.win32.WinPlatformOperationsProvider: org.eclipse.core.runtime.CoreException: Plug-in "com.ibm.cic.agent.core.nativeInstallAdapter.win32" was unable to instantiate class "com.ibm.cic.agent.internal.adapters.nativeAdapter.win32.WinPlatformOperationsProvider". Error getting file for installation: zip com.ibm.cic.agent.nativeAdminFixup 1.0.0.20090127 Failed to locate previously fetched file at C:\Program Files\IBM\Installation Manager\eclipse\native\com.ibm.cic.agent.nativeAdminFixup_1.0.0.20090127.zip. CRIMA1075E: Unable to find custom install operation com.ibm.cic.agent.nativeAdminFixup.NativeAdminFixup com.ibm.cic.agent.nativeAdminFixup.NativeAdminFixup


permanent link
Shirley Jhirad (514150) | answered May 30 '13, 3:40 a.m.
Hi Girish,

Were you able to solve the issue in the end?

I am trying to install the Installation Manager and get the same error again and again, although i have changed the Installation files folder to be straight under C:\ and there are no spaces in the folders name.

Then i tried to re download the installation pack but i still get the same errors.

Can anyone advise??

Thanks
Shirley

Your answer


Register or to post your answer.