It's all about the answers!

Ask a question

Hide password for scm login with tomcat


Anders Truelsen (16212020) | asked Aug 13 '12, 5:11 a.m.
We have build scripts (sh) that call scm.exe.
How do I avoid having the password flashed in plain text in all my scripts?

We're running RTC 3.0.1 on Tomcat.

Accepted answer


permanent link
Ralph Schoon (63.2k33646) | answered Aug 13 '12, 5:24 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi Anders,

I have seen some discussions around this and this post https://jazz.net/forum/questions/74823/how-to-pass-an-encrypted-password-file-to-scm-cli contains an answer, where I collected posts that discussed this.

<quote>According to several posts, you can use the -c option and the file repositories.txt. I haven't tried. Apparently the daemon encrypts user and password and stores that in a file. You can keep the file and use it for login, as far as I understand.

See:
https://jazz.net/forums/viewtopic.php?t=12096
https://jazz.net/forums/viewtopic.php?t=20364
https://jazz.net/forums/viewtopic.php?t=6613

for more details and try out the advanced search to find more information.</quote>
Anders Truelsen selected this answer as the correct answer

Comments
Anders Truelsen commented Aug 13 '12, 5:45 a.m.

Cheers Ralph

I'll take a look at it and let you know how it works :-)

regards /anders

One other answer



permanent link
Martin Wassermann (13864144) | answered Jan 18 '13, 5:06 a.m.
edited Jan 18 '13, 5:13 a.m.

I want to avoid entering the password, too. Therefor I have created the repository.txt file throug using the login command
lscm --config data login -r <repository> - u <user>  -P <password> -c -n rtc

Now I want to use this stored password. I tried this with following command
lscm --config data load -r rtc -u <user> <Repository Workspace Name>

But he still wants my user credential. Does anybody see what I do wrong?

PS: I use the -u option because I want to login with a user that differs from my window user. Otherwise he always take my windows user.


Comments
Ralph Schoon commented Jan 18 '13, 5:09 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Have you looked into the links in the answer above? I believe they contain information that should get you running.


Martin Wassermann commented Jan 18 '13, 5:13 a.m. | edited Jan 18 '13, 5:13 a.m.

Yes I have looked in the answer above. There I found the --config option. But in my script he didn't uses the stored connection, and I don't know why.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.