It's all about the answers!

Ask a question

Doors 9.4 - RQM V4 OSLC inegration issues


Mark Ireland (26115347) | asked Aug 09 '12, 10:26 a.m.
We are having an issue with Doors - RQM integration using OSLC, details are :-

we have set up integration, friends inbound outbound etc
we go to a test plan, then select, Requirements collection Links
select add, we get the doors structure all ok, and can navigate np
we select a view and ok, it comes back again no issue, and is now in the links list
when we save the test plan, we get "Unable to load /qm/proxy... LOTS OF STUFF status:403"

I have redone friends etc
Error below.

Unable to load /qm/proxy?uri=https%3A%2F%2Fcerb-rat-01p%3A36677%2Fdwa%2Frm%2Furn%3Arational%3A%3A1-501fb6a36e433cc7-M-00000020%2Fview%3A00000006 status:403

All users are Doors database admins or Rational admins, have lics, etc

9 answers




permanent link
Martin Henderson (16) | answered Aug 10 '12, 5:35 a.m.
JAZZ DEVELOPER
This would suggest that there is an issue accessing the DOORS view when adding as a requirement collection link to the Test Plan.

Can I ask for some further information on the view being used:

1. Is it a public view or are there some restrictions to it?
2. Is it in a baseline module?

Also some general information on the DWA installation would be appreciated - how many interops?

Comments
Boris Samaru commented Aug 13 '12, 9:50 a.m.

Hi Martin,

Mark is doing the integration for our project. We tried it with a Public View in DOORS, just to be sure, with no baselines. (Just a couple of noddy requirements, created afresh). Same results as described above.


permanent link
Paul Tasillo (10665) | answered Aug 14 '12, 7:09 a.m.
JAZZ DEVELOPER
Do any users have the view open for write? Back linking to the view won't work if anyone has the view open for write. 
What versions of the products are you using? What browser / version? 
Does linking from test cases to requirements directly work? 

Thanks


permanent link
Mark Ireland (26115347) | answered Aug 14 '12, 8:02 a.m.
Hi,

Nope, these are specifically created for test, nobody has them open etc.
Browsers are exactly as per the V4 requirements, FF 10 esp, and IE 9




permanent link
Mark Ireland (26115347) | answered Aug 14 '12, 8:03 a.m.
One thought was that this was caused by certification issues, unable to connect returns a 403 forbidden message that we would normally click on and say continue, just  in this case it is unable to......

Does that make sence?

permanent link
Paul Tasillo (10665) | answered Aug 14 '12, 8:25 a.m.
JAZZ DEVELOPER
 Can you log into DWA from the same browser? This is a issue where RQM is trying to proxy a request to DWA. 


permanent link
Mark Ireland (26115347) | answered Aug 14 '12, 8:30 a.m.
Hi,

yes, log on to DWA with same browser(s) no issues.
DWA is set to https etc...



permanent link
Boris Samaru (111) | answered Aug 14 '12, 8:34 a.m.
Hi Paul,

It is DOORS 9.4 and RQM 4.
Linking a Test Case to a requirement gives the same result.
We have tried multiple browsers, but the version of IE is IE9.08
The Rational engineers are currently looking at an Infrastructure area (Security Certificates)
to see if this helps, since we are on a standalone secure network with a tighter lockdown than
many of the other working (non-secure & non-standalone) solutions.

Many Thanks,

Boris

permanent link
Boris Samaru (111) | answered Aug 15 '12, 5:13 a.m.
Hi All,

Thank you for your help.
We have now resolved the main issue. There was a configuration problem in DOORS, so the URLs for modules and objects were being published with the incorrect port number.

*** We can now do the basic linking from DOORS requirements to RQM Test Cases and Scripts. ***

Your answer


Register or to post your answer.