It's all about the answers!

Ask a question

V4 response time very slow


0
1
sam detweiler (12.5k6188201) | asked Jul 31 '12, 12:03 p.m.
edited Jul 31 '12, 12:05 p.m.
I have installed V4 release (had the rc0 before that)..

web operations are slow as molasses

logging on takes forever (>200 seconds)
open a workitem (via url paste intpo browser)  well, I am in 5 minutes but no results yet

start V3.0.1.1 and login takes <1 minute 1st time, and a few seconds second time on
open workitem (via url paste intpo browser) takes a few seconds

I had this same slowness on RC0, but assumed it was debug type info..

this is an Intel i7 2600 processor, 16gig of ram, running windows 7 (64bit). nothing else is going on.
(outlook is running) 7 of 16 gig used. cpu utilization <5%

one point on this system..

the system URL is mapped to a fixed IP address on the internet thru my router.
the installed RTC server name string is mapped in my hosts file to localhost. so that requests from internal and external systems work

how can I debug this slowness?

I am attempting to implement an OSLC mini viewer function on one of my app systems, and I need my server to respond in sometime reasonable.

help

(I have run all prior versions on this system without issue, and still have V3.0 and 3.0.1.1 installed which don't exhibit this problem)

Sam

Accepted answer


permanent link
Ralph Schoon (60.9k33643) | answered Aug 01 '12, 6:07 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
One other thing we just run into recently: do you run on a VMWare without internet connection? There is an issue with DNS lookup. See the workitem below for a work around.

https://jazz.net/jazz/resource/itemName/com.ibm.team.workitem.WorkItem/216290

 
sam detweiler selected this answer as the correct answer

Comments
sam detweiler commented Aug 01 '12, 9:31 a.m.

thank you thank you ... while not a VMWare problem, it WAS a DNS problem.. seems my local router has lost its DNS proxy capability.. reconfiguring the router to send the ISP dns server to the clients and all the perf issues are gone..

sounds like V4 does a ton more DNS lookups than V3. maybe there is a better way to clean that up.. we will have to make sure to look at this when we start with V4 testing.

8 other answers



permanent link
Matt Lennon (61225) | answered Jul 31 '12, 3:01 p.m.
JAZZ DEVELOPER
 Hi Sam.  RTC 4.0 has a new tool that lets you quickly check for basic plumbing problems - poor network throughput or latency, DB sluggishness, etc. Read more about the "Performance Health Check" widget here:

      https://jazz.net/blog/index.php/2012/05/15/performance-health-check/

This tool won't diagnose more complex server or network configuration issues, but it's a good place to start.

     -Matt

permanent link
sam detweiler (12.5k6188201) | answered Jul 31 '12, 4:42 p.m.
edited Jul 31 '12, 4:43 p.m.
thanks.. getting the dashboard up was painful..  >20 minutes

round trip is 53ms
db latency is 0
download is 19787kb
upload is 24824kb.

don't SEE anything obvious

DB is the built in derby DB

permanent link
Ralph Schoon (60.9k33643) | answered Aug 01 '12, 5:54 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Have you tried : https://jazz.net/library/article/822

You can get the data in 4.x if you download the diagnostics from the diagnostics page.

I am running 4 on my i7 laptop with Tomcat/Derby all the time and it is fast as you could ask for. So I am not sure what you are facing.

Comments
sam detweiler commented Aug 01 '12, 9:11 a.m.

I am not using VMWARE, this is running native on Windows 7 64bit. accessing the counters zip file took 20 seconds to get the new login screen up from a browser tab, where the same user was already logged into CCM..

is this a tomcat 7 problem?


permanent link
Canberk Akduygu (99237271) | answered Aug 01 '12, 6:32 a.m.
I had a similar situation with a client during a POC with version 4.x. We only installed JTS and RQM application. We managed to solve the issue by installing products 3.x version. The configuration was 4 GB Ram, i5, Win 2008 R2  o the machine during POC.

There was no WM :(

permanent link
Frank Ning (50024117131) | answered Aug 01 '12, 8:36 a.m.
Based on Canberk's comments, it seems not just VM issue. I am having the same issue on VMs. Unfortunately,  the workaround mentioned in the defect does not work for me. It takes very long time to open anything for the 1st time or whenever the application servers gets restarted. After the 1st hit of any page, the following hit on the same page will be quite quick.  My users have been complaining about this. The VM has 12 GB RAM and 4 cores on ESX and this issue is not related to the number of users. It behaves the same even when a single user uses the system.

I added some comments to the defect. Hopefully the Rational guru can find some solution to this.

permanent link
Canberk Akduygu (99237271) | answered Aug 01 '12, 8:59 a.m.
Exactly, the first time is painfull. It took me 5 minutes to open the RQM dashboard but after that it's really fast. If I close the browser same problem occurs.

One of my collegues stated that he encountered this issue in a WM. He had CQ-WebSphere AppServer,Doors Web Access and RQM installed on it. Everything seems to work fine except for RQM.

I'll contact to my customer about the configuration if I remember wrong about the machine being non-WM. May be I mis-remember it.



permanent link
Ralph Schoon (60.9k33643) | answered Aug 01 '12, 9:30 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi Sam,

I ran the V4 - multiple instances on my machine. Plain install, Derby and it works like a charm. So no. I would suggest to open an PMR.

permanent link
Sterling Ferguson-II (1.6k7264264) | answered Aug 01 '12, 9:47 a.m.
Hello,

We have 2 installations with similar issues. One was fine with v3.x until we upgraded, the other was a clean v4.0 install.

I posted, during beta, that I thought v4.0 seemed slow, but I thought that was a beta thing. It wasn't a machine issue on our side, as we ran beta tests off of the IBM cloud.

Comments
Ralph Schoon commented Aug 01 '12, 10:22 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Hi Steriling, Sam just confirmed that he has a DNS issue. You might see something similar. And if the cloud image has DNS issues as well, you would see it. But it would be very slow. If it is just a bit slow I would guess, maybe the virtualization provides the processing power and resources to too many cpu's. And rumor has it, some virtualzations throttle down the CPU based on resources in use too. If the CPU load is low you don't get as much CPU. This could cause delays on your end if the machine in not permanently on high load.

Your answer


Register or to post your answer.