It's all about the answers!

Ask a question

Error: Internal error on deliver

Phillip Piper (15812524) | asked Jul 17 '12, 9:18 p.m.
We use and had a user attempt to deliver change sets from a Team stream to an Integration stream directly. When this was attempted the following error occurs:

Error: Internal error

Require a work item, comment, or change request when a change set is delivered.

We do have the Require Work Items and Comments precondition enabled for a few roles and we have it set to require both associated work items and work item owners. Now, I went through every single change set in detail (1100+) and checked all 695 associated work items. Unless I made a mistake all change sets have an associated work item. And each work item has an owner and is in the same project area as the streams.

I have no idea why we are getting the message above and usually the Problem section gives a better message. Does anybody have any ideas? Thanks in advance.

Gustavo Monti Rocha commented Sep 29 '15, 9:11 a.m. | edited Sep 29 '15, 11:00 a.m.

 Hi, I'm with the same problem. I'm trying to deliver 470 changeset and turned off the precondition (now it should have a comment OR a work item do deliver) and dind't work. I checked and all changesets have a comment OR a work item.

I tried to see this but it was not investigated: 

How to fix it? Any workaround?

I'm using RTC 5.0.2 version.

Geoffrey Clemm commented Sep 29 '15, 11:09 a.m.

There are several problems with Gustavo's post.
First: It was posted as an "answer", when it clearly is either a comment or a question (I converted it to a comment, but in these situations, a new question with a reference to the old question would get more attention).
Second: The quoted work item clearly states that the problem was not reproducible.  So saying it "was not investigated" is incorrect.  
Third: As stated in the answer, you have to contact support ... an "Internal Error" isn't something that can be worked around via a forum discussion.

One answer

permanent link
David Olsen (5237) | answered Jul 18 '12, 7:40 p.m.
The text "Internal error" means it's a bug in the product.  You should contact support or file a defect.  There might be a workaround that you can use in the meantime, but it is hard to say what that would be until someone looks into the problem in more detail.

My best suggestion for what to do right now is to temporarily turn off the precondition.  Since you have manually verified that the precondition is indeed satisfied, turning it off for this one delivery is unlikely to cause problems.

-- David Olsen, IBM Rational, Jazz Process Team

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.