It's all about the answers!

Ask a question

WebUI: Copy & Paste text from non-ASCII/ANSI sources into Edit Comment causes next text added to jump back to position before paste


Eric Jodet (6.3k5111120) | asked Jun 29 '12, 8:50 a.m.
JAZZ DEVELOPER
edited Jun 29 '12, 6:24 p.m. by Geoffrey Clemm (30.0k23035)
Using RTC 3.0.1.3 WebUI
Exercising the copy/paste of text, I found that the cursor has an incorrect position upon paste,
when pasting content with non-ASCII chars.

Steps to reproduce:
1. Add a comment and write: "Hello, trying "
2. Copy and paste from Word: "copy & paste"
3. Start to type " from Word"

At this point, the behavior found is: some characters may be written after "copy & paste", the rest are written before.
Therefore you may have the following result:
"Hello, trying Word copy & paste from"

Is this a bug?

One answer



permanent link
Eric Jodet (6.3k5111120) | answered Jun 29 '12, 8:52 a.m.
JAZZ DEVELOPER
yes - this issue has been identified on jazz.net as defect # 200932
which was found fixed "along the way" in RTC 4.0 as part of the work related to the Rich Text Editor.

Hence this issue is still present in 3.X.
However, the work arounds found are as follows:
1. copy the text to a Notepad and then copy it from Notepad to the Work item's Comment field
2. in the comment field, after having pasted the text, hit "home", mark something that you typed in before (I guess: which was not pasted), then Ctrl-C, "end", Ctrl-V, and backspace to remove this again.

Your answer


Register or to post your answer.