It's all about the answers!

Ask a question

How to exclude subteams from iteration plans (RTC 3.0.1.3)


Dieter Schmidt (4123) | asked Jun 20 '12, 6:22 a.m.
I have created an iteration plan for a certain iteration, the owner is set to a certain team (which has one subteam). I found that the data shown in the progress bar of the iteration plan always includes data from the subteam.

Is there a way to create an iteration plan which does only consider items from a 'parent' team, and ignores work items from subteam(s) ?

I found that I can easily filter subteam workitems from appearing in plan views, but although no longer showing in a plan view, the subteam work items still contribute to data in the progress bar. How do I prevent subteam work items from contributing to the progress bar ?

Thanks
Dieter

Comments
Arne Bister commented Jun 20 '12, 8:13 a.m.
JAZZ DEVELOPER

Hi, I would like to help find a good resolution for this. To set up a test environment, could you just point me to some details? What process template do you use? (e.g. SCRUM or Formal Process) Are you using web client? Which plan view do you use? (e.g. Iterations, Work Breakdown, ...)

Thanks, Arne


Dieter Schmidt commented Jul 02 '12, 10:56 a.m.

Hi Arne, I'm using RTC 3.0.1.3 with the SCRUM process template. I usually work with the web client but do also use the eclipse client from time to time. The plan view being used is 'work breakdown' , but I did try with others as well. Dieter

One answer



permanent link
Dieter Schmidt (4123) | answered Jun 28 '12, 6:57 a.m.
... quick update for those who might have a similar problem .... I found a means to exclude sub-team data from being accumulated into the plan progress bar (not sure if that is how it should be done - but it works for me).

I managed to do this in the web client only (it might also be possible in the eclipse client, but I did not find the place to change it in the eclipse client).  Here is what I found:

1. Open a plan in the web client
2. open/edit  plan details
3. Remove the checkmark for 'Include All Items' to prevent data from subteams to count for the progress bar (this will also prevent them from being shown in the plan). Checkmark the option again to include sub-team data. Note that, although the displayed plan items look similar to what is shown when filtering 'Items from Subteams',  the checkmark effects what is shown in the progress bar, the filter does not.

Not sure what other side effects this has, but it works for me. Would appreciate if someone who has more knowledge can comment.

Regards Dieter

Your answer


Register or to post your answer.