It's all about the answers!

Ask a question

REST API in RQM 3.0.1 not working ?

Pranam Codur (654) | asked Jun 12 '12, 6:13 a.m.

We are using RQM 3.0.1. The typical URL to get a test case feed is:
https://<server>:<port>/jazz/service/<projectalias>/testcases . We had configured "jazz" to be the context root. My user id has administrator privileges for the project area.

On HTTP GET I get  a 501 error status.
Status report

The server does not support the functionality needed to fulfill this request ().

I wondered maybe my project alias is incorrect so I tried to access the "projects" feed and I get a 403 error. My license is of the type "Quality Professional".

What might be going wrong at my end ?


3 answers

permanent link
Pramod Chandoria (2.1k11220) | answered Jun 12 '12, 9:44 a.m.
A user with Jazz user role and Administrator of a project area should be able to open project feed as well testcase feed. There must be some other problem. Check if any other user is also affected with this symptom or you are the only affected user.

permanent link
Paul Slauenwhite (8.4k12) | answered Jun 12 '12, 2:33 p.m.
Change testcases to testcase in the URL.

permanent link
Pranam Codur (654) | answered Jun 12 '12, 10:17 p.m.
Thanks Paul and Pramod.

The other thing I did that solved my problem was to use the RQMURLUtility.jar


Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.