It's all about the answers!

Ask a question

Problem importing a Perforce/SVN data dump

Dana Maxfield (2346) | asked Jan 16 '12, 3:51 p.m.
We are in the process of migrating from Perforce to RTC. Part of this process involves exporting the data from Perforce (using into a SVN dump format (this is so we can maintain the data change history which is required). We currently have the need to export/import data on one weekend, and then export/import the delta's at a later date. When I try to do this, I get two results:

- I export the entire data structure from Perforce, including the deltas. When prompted, I instruct the import to start importing after revision #X (X=the last revision I imported to RTC). The import then processes starting from revision #1, and fails with the following message:

Problems occurred running import from svn.

An error occurred importing "Revision 1: (1/16/12 8:51 AM) New test area':
Parent has multiple children with the name 'pt_br'.

(pt_br is one of our top level folders)

- I export ONLY the deltas from Perforce. Doing this could only export the data files, and not the directory structure as well. When I get to the import screen entitled "Choose SVN Folders to Import", I do not see any folders listed, and therefor the "Next" and "Finish" buttons are not available.

Does anyone have any experience in importing deltas? Do I have other options on how this could be accomplished?

5 answers

permanent link
Dana Maxfield (2346) | answered Jan 18 '12, 11:50 a.m.
Has anyone done a Perforce migration into RTC before that might be able to offer input?

permanent link
Alan Hadsell (611) | answered Jan 18 '12, 5:48 p.m.
I'm seeing the same error on an import from Subversion, so I don't think it's specifically a Perforce problem.

BedBath User commented Jun 12 '12, 12:56 p.m.

also seeing the same error on import from Subversion, even though I say to import starting at revision gives me an error that "an error occurred importing Revision 2...

permanent link
John Bayley (122) | answered Oct 10 '14, 2:12 p.m.
I am also seeing the same error while trying to import a branch from Subversion. This follows a successful import of the "trunk."

Did anyone figure out a workaround for this problem?

permanent link
Dana Maxfield (2346) | answered Oct 13 '14, 11:00 a.m.
We did eventually get around this error.
We stopped using the script and created our own java process, and continued to see this error when importing delta dumps (data that was checked into Perforce AFTER our intial dump creation). To address this, we have used the following option during the import wizard "Reconcile any overlap between existing and imported files and folders." This option is on the same screen where you can set the name for the baseline, and the starting/ending revision numbers. When using this option, we don't get an error. Once the import was complete, we have done a file by file comparison and found everything is the same.

permanent link
John Bayley (122) | answered Oct 15 '14, 1:02 p.m.
Thanks for following up. In our case, the fundamental problem is that the migration tool isn't creating baselines in RTC that map to the branch creation points in RTC. We saw the error above when trying to import a branch into a stream containing the baseline that marks where the trunk was imported, which doesn't really make sense

Finding a way to create those baselines is a different problem...

Your answer

Register or to post your answer.