It's all about the answers!

Ask a question

RTC 3.0.1.3 and RRDI?


Frederic Mora (13811518) | asked Apr 03 '12, 2:08 p.m.
retagged Feb 08 '13, 6:27 p.m. by Amy Laird (16514)
Hello,

We are going to upgrade our RTC installation from 3.0.1 to 3.0.1.3.

The upgrade procedure has a few repotools steps to change the DB. We need to know if RRDI is also impacted or if it will be compatible with the modified database.

Any idea?

8 answers



permanent link
Francesco Chiossi (5.7k1719) | answered Feb 08 '13, 4:42 a.m.
This article clarifies the CLM to RRDI/Insight version compatibility:
Version Compatibility Matrix for Rational Reporting for Development Intelligence, Rational Insight, and CLM

permanent link
Geoffrey Clemm (30.0k23035) | answered Apr 04 '12, 12:22 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
It should be the case that there are no incompatibilities introduced in a 4'th digit release. So there "should" be no issues, and I personally am not aware of any issues, but to be certain, we'll want someone from the RDDI team to confirm.

Cheers,
Geoff

Hello,

We are going to upgrade our RTC installation from 3.0.1 to 3.0.1.3.

The upgrade procedure has a few repotools steps to change the DB. We need to know if RRDI is also impacted or if it will be compatible with the modified database.

Any idea?

permanent link
Frederic Mora (13811518) | answered Apr 04 '12, 6:07 p.m.
It should be the case that there are no incompatibilities introduced in a 4'th digit release. So there "should" be no issues, and I personally am not aware of any issues, but to be certain, we'll want someone from the RDDI team to confirm.



Thank you. Can you please tell me how I can reach an RRDI team member? I could always open a PMR, but this is a bit heavyhanded.

permanent link
Jackie Albert (1.6k14844) | answered Apr 04 '12, 11:13 p.m.
Thanks - I have the same concern, although we're going from 3.0.1.1 to 3.0.1.3 and use Insight. It wasn't clear in any of the release notes whether there are data model, XDC, or ETL updates released with this version.

permanent link
Rosa Naranjo (2.9k11423) | answered Apr 05 '12, 12:33 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
Hello
The optional programs page for the 3013 download still lists RRDI 1.0.2.1 for the RRDI download. RRDI 1021 was released with RTC 3012. From the perspective of the DW, any updates needed would be handled via the repotools-jts -createwarehouse command as part of the upgrade to RTC 3013.

http://publib.boulder.ibm.com/infocenter/clmhelp/v3r0m1/index.jsp?topic=%2Fcom.ibm.jazz.install.doc%2Ftopics%2Ft_upgrading_3011.html

http://publib.boulder.ibm.com/infocenter/clmhelp/v3r0m1/topic/com.ibm.rational.rcpr.help.doc/topics/t_upgrade_rrdi102_to_rrdi1021.html

Hello,

We are going to upgrade our RTC installation from 3.0.1 to 3.0.1.3.

The upgrade procedure has a few repotools steps to change the DB. We need to know if RRDI is also impacted or if it will be compatible with the modified database.

Any idea?

permanent link
Geoffrey Clemm (30.0k23035) | answered Apr 05 '12, 12:37 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
You could try posting to the Insight forum on jazz.net.
But if you don't get a response either here or there, your best bet is calling Rational Support.

But note that if there are any incompatibilities between 4'th digit releases (other than bug-fixes in later 4'th digit releases), then I'd consider that a bug.

Cheers,
Geoff

It should be the case that there are no incompatibilities introduced in a 4'th digit release. So there "should" be no issues, and I personally am not aware of any issues, but to be certain, we'll want someone from the RDDI team to confirm.



Thank you. Can you please tell me how I can reach an RRDI team member? I could always open a PMR, but this is a bit heavyhanded.

permanent link
Jackie Albert (1.6k14844) | answered Apr 05 '12, 8:03 a.m.
You could try posting to the Insight forum on jazz.net.
But if you don't get a response either here or there, your best bet is calling Rational Support.



Since the CLM teams are responsible for the data model, ETL's and related updates that are used by Insight it seemed more appropriate to ask here. I also thought that opening a PMR seemed a little too extreme for this kind of question.

permanent link
James Paulus (20621831) | answered Sep 07 '12, 5:40 p.m.
So, can we put RRDI 2.0 on a 3.0.1.3 release?   We are eventually going to upgrade to 4.0 but are wondering if we could do the RRDI install first?   This article (https://jazz.net/library/article/632) seems to indicate nothing about RRDI 2.0 but it is also before it was released.

Thanks!

Comments
Jim Tykal commented Feb 08 '13, 1:02 a.m.
JAZZ DEVELOPER

James, did you get an answer on this? Is RRDI 2.0 compatible with RTC 3.0.1?


James Paulus commented Feb 08 '13, 8:25 a.m.

Yes, based on Francesco's comment and other forum questions on this topic I have found out that we can do 3.0.1.3 and RRDI 2.0.1.

Your answer


Register or to post your answer.