It's all about the answers!

Ask a question

Not taking effect after changing the process?


Jirong Hu (1.5k9292258) | asked Nov 11 '11, 4:25 p.m.
Hi

After I got this error, I tried remove the "Descriptive Change Set" and now completely disabled the pre-condition. But I am still getting this error. Is there anything I need to do after changed the process configuration?

Then I found I have to remove this pre-condition from the Requirement Phase (the current iteration). Why change in the Team Configuration is not enough?

Thanks
Jirong

http://i42.tinypic.com/301dgn6.png

4 answers



permanent link
Geoffrey Clemm (30.1k33035) | answered Nov 11 '11, 11:53 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
There is also a check for this in Deliver(server).
You need to modify/remove the "Require Work Items and Comments"
precondition.

(I believe the check in Deliver(client) is just a remnant from when
there was not such check in Deliver(server).

Cheers,
Geoff

On 11/11/2011 4:38 PM, hujirong wrote:
Hi

After I got this error, I tried remove the "Descriptive Change
Set" and now completely disabled the pre-condition. But I am
still getting this error. Is there anything I need to do after
changed the process configuration?

Thanks
Jirong

http://i42.tinypic.com/301dgn6.png

permanent link
Jirong Hu (1.5k9292258) | answered Nov 14 '11, 10:30 a.m.
There is also a check for this in Deliver(server).
You need to modify/remove the "Require Work Items and Comments"
precondition.

(I believe the check in Deliver(client) is just a remnant from when
there was not such check in Deliver(server).

Cheers,
Geoff


As you can see below, there is nothing in both client and server.

Then I found I have to remove this pre-condition from the Requirement Phase (the current iteration). Why change in the Team Configuration is not enough?

And the good news is I finally did a successful import after 44 hrs.

http://i40.tinypic.com/m7rnr8.png

permanent link
Geoffrey Clemm (30.1k33035) | answered Nov 14 '11, 7:53 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Glad to hear that removing that process check allowed the sync to succeed.

Your process is defined by the "most precise" area that is configured
for that operation. In order of decreasing preciseness:
- the current iteration
- the iteration type of the current iteration
- the team area that owns the object being modified by the operation
- the nearest parent team/process area of the team area in the previous
bullet.

So if there is a Deliver(client) check in the current iteration, that
takes precedence over any other checks for Deliver(client).

Cheers,
Geoff

On 11/14/2011 10:38 AM, hujirong wrote:
gmclemmwrote:
There is also a check for this in Deliver(server).
You need to modify/remove the "Require Work Items and
Comments"
precondition.

(I believe the check in Deliver(client) is just a remnant from when

there was not such check in Deliver(server).

Cheers,
Geoff

As you can see below, there is nothing in both client and server.

Then I found I have to remove this pre-condition from the Requirement
Phase (the current iteration). Why change in the Team Configuration
is not enough?

And the good news is I finally did a successful import after 44 hrs.

http://i40.tinypic.com/m7rnr8.png

permanent link
Qiong Feng Huang (76911610) | answered Nov 17 '11, 6:29 a.m.
JAZZ DEVELOPER
There is a article you might be interested in: Process behavior lookuphttps://jazz.net/library/article/33. Process permission lookup https://jazz.net/library/article/32

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.