It's all about the answers!

Ask a question

Can not update attribute

pan tianming (4765644) | asked Oct 23 '11, 11:10 p.m.
We have three attributes with the type of "text", but in our Test Environment and Dev environment we are not able to update their value. Our dev and test environment using the same library and same RAM version testFix902fa

Detail behavior:
When update this asset, input some value on the asset attribute, then click update button, the screen shows successfully updated. But when check the asset again it shows empty value for these attributes whatever the value you input.

1) Dev environment: Using RAM admin user and normal RAM user both have problem to update these attributes, they always show blank value after updated. FireFox browser has problem but IE no problem.

2) Test environment: Using RAM admin user can update attribute, but normal RAM user can not. Both Fireffox and IE browser has this problem.

8 answers

permanent link
Sheehan Anderson (1.2k4) | answered Oct 24 '11, 10:12 a.m.
What versions of IE and Firefox are you using? RAM supported Firefox 3, Firefox 3.5, IE 6 SP1, and IE 7.

permanent link
pan tianming (4765644) | answered Oct 24 '11, 10:59 p.m.
I am using FireFox 3.6.23 and IE8.

Also, for other attributes are no problem to be edited, just these three asset attributes.

permanent link
Sheehan Anderson (1.2k4) | answered Oct 25 '11, 6:15 p.m.
If you try to update one of those three attributes with a supported browser (Firefox 3 or IE6/7) does it work in both environments or does the update still fail?

permanent link
pan tianming (4765644) | answered Oct 26 '11, 3:45 a.m.
Today I used IE7 to test this issue, still the same problem.

permanent link
Sheehan Anderson (1.2k4) | answered Oct 28 '11, 10:03 a.m.
Could you check to see if there are any messages in the ramDebug.log file or SystemOut.log file at the times you try to update the attributes? You can reach the logs files by navigating to Administration -> Tools -> All support logs.

Also, are you able to update the attributes from the eclipse client or does it fail there also?

permanent link
Gili Mendel (1.8k56) | answered Oct 31 '11, 2:58 p.m.
Make sure these attribute/s are not restricted:

go to the type (you are uploading) configuration, and look at the way the attribute is configured for it, ... make sure that everyone can update these attributes (i.e., these attributes were not restricted to specific users).

permanent link
pan tianming (4765644) | answered Nov 21 '11, 3:40 a.m.
We have checked following:
1) Compare the RAM debug log before set this attribute from UI and after that, the ram log is no any change.

2) When try to use RAM client API to set value, it is no problem, This issue only happen when using RAM UI.

3) There is no any Constraints defined for this attribute after check Asset type constraint page.

permanent link
pan tianming (4765644) | answered Nov 21 '11, 8:44 p.m.
We have resolved this problem, the solution is must delete all of the attribute constraints under that asset type, then attribute can be updated.
Previously we only check the attribute constraint related with that has problem for update, not notice must remove all of attribute constraints

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.