It's all about the answers!

Ask a question

Report BIRT - Date parameter problems

Matias Rodriguez (4611011) | asked Sep 26 '11, 11:30 a.m.
I am having problems with 2 of the parameters of my report. When previewing the report in the eclipse, data is succesfully shown, but when running in server, no data is showed. I tried setting default parameter values and now the data is successfully shown, but when i try to edit them i get NaN/NaN/NaN in the date text box, and if i select a new date, the report will have no data, again.

4 answers

permanent link
Marcell Szabo (11) | answered Jul 03 '12, 9:45 a.m.
Same problem here :(

permanent link
Vladimir Amelin (70472226) | answered Jul 03 '12, 10:02 a.m.
I've seen such problems in RTC 2.x but in 3.x it's OK. Which one do you use?

permanent link
Marcell Szabo (11) | answered Aug 30 '12, 9:41 a.m.
Our version is 3.0.1, and I tried to use a BIRT function: as a defult value

permanent link
James Cole (9532230) | answered Sep 11 '12, 4:48 a.m.
Hi Vladimir, 

What version have you seen this working in? I have the same issue in RTC 3.0.1.

Also what browser & version did you test this in?

Many Thanks


Vladimir Amelin commented Sep 11 '12, 5:01 a.m.

We had 2.0 and then upgraded to 3.0.1. I've observed the issue with DateTime type, but no with Date type. It's gome after saving some parameter value, reproduced for parameter with no default value only. Looks like RTC wrapper is too captious about format of input value.

Your answer

Register or to post your answer.