It's all about the answers!

Ask a question

Birt Report : Design file has error and report cannot run


Martin Lee (3676) | asked Jun 20 '11, 4:26 a.m.
JAZZ DEVELOPER
Hi,

I have CLM 3.0 RC2 installed and it is running fine. I did a report design in BIRT and it was running fine in the Report Designer perspective of the Rational Team Concert client.

However, when I added the report to the report template and ran it in the Work Item perspective and the web interface of Team Concert, I have the above error, any idea what could have gone wrong?

4 answers



permanent link
Eduardo Bello (4401821) | answered Jun 20 '11, 8:43 a.m.
It would be easier if you inform what is the error message.

But you can check the version showed at the 2nd line of your xml. I'm not sure about CLM 3.0, but until RTC 3.0 iFix1 the report should be at version 3.2.21.

If you installed a recent version of BIRT, it generates reports with recent version like 3.2.22. And those reports works fine in Report Designer, but once you deploy it to server you got an error. If this is your case, you can just change manually the version in XML source to 3.2.21.

permanent link
Martin Lee (3676) | answered Jun 20 '11, 10:44 p.m.
JAZZ DEVELOPER
It would be easier if you inform what is the error message.

But you can check the version showed at the 2nd line of your xml. I'm not sure about CLM 3.0, but until RTC 3.0 iFix1 the report should be at version 3.2.21.

If you installed a recent version of BIRT, it generates reports with recent version like 3.2.22. And those reports works fine in Report Designer, but once you deploy it to server you got an error. If this is your case, you can just change manually the version in XML source to 3.2.21.


Thanks a lot. It works when I change the XML source to 3.2.21.

permanent link
Martin Lee (3676) | answered Jun 22 '11, 9:48 p.m.
JAZZ DEVELOPER
It would be easier if you inform what is the error message.

But you can check the version showed at the 2nd line of your xml. I'm not sure about CLM 3.0, but until RTC 3.0 iFix1 the report should be at version 3.2.21.

If you installed a recent version of BIRT, it generates reports with recent version like 3.2.22. And those reports works fine in Report Designer, but once you deploy it to server you got an error. If this is your case, you can just change manually the version in XML source to 3.2.21.


Thanks a lot. It works when I change the XML source to 3.2.21.

I have another issue with the chart. The chart size and display looks good in Birt but when published and view in RTC, the chart becomes small and the labels are not displayed. Any idea why is that so?

Your answer


Register or to post your answer.