It's all about the answers!

Ask a question

Diff for XAML files in change set view


James Clarke (21122) | asked Jan 10 '11, 8:02 a.m.
I am using RTC 3 and have some files with .xaml extensions. These are just text files but the change set explorer (viewed via the web interface in browser) does not show a diff for these files. It gives this reason:

Differences between the Before and After states of the file cannot be computed
because neither of the content types of the states can be displayed: application/unknown, application/unknown

Works just fine for other files, .cs for example.

Any help greatly appreciated,

James

12 answers



permanent link
Sreerupa Sen (1.0k4) | answered Jun 24 '11, 7:32 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
You could multi-select the files in the Solution Explorer and choose the Jazz Properties menu option. That brings up a single Jazz properties dialog where you can change the MIME type of multiple files.
The Jazz Properties dialog if opened for multiple files will show only properties that are the same across all files - say maybe repository URL, component etc. If the files have different MIME types, it will display a blank for the for MIME type property value, but if you then set it to a specific value the VS Client will set it across all the files you selected.


Cheers,
Rupa

permanent link
Ralph Schoon (61.4k33643) | answered Jan 11 '11, 8:18 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi James,

what I just tried (Eclipse) was:

Go to the Eclipse>Window>Preferences

In Team>Jazz Source control>File Properties it is possible to add extensions to the text resource type.

Also on the file in the context menu Team>Change File Properties you can modify this for just one file.

There might be more options to do so, I might even be missing something but that would be what I'd try.

How did you get these files a being recognized as binary? At least my Eclipse, if I create a file manually I always get text type. Are there other associations or settings in the Eclipse properties?

Ralph

I am using RTC 3 and have some files with .xaml extensions. These are just text files but the change set explorer (viewed via the web interface in browser) does not show a diff for these files. It gives this reason:

Differences between the Before and After states of the file cannot be computed
because neither of the content types of the states can be displayed: application/unknown, application/unknown

Works just fine for other files, .cs for example.

Any help greatly appreciated,

James

permanent link
James Clarke (21122) | answered Jan 11 '11, 9:32 a.m.
I'm using Visual Studio with the RTC plugin.

Our RTC admin has Eclipse and we did try adding an entry for *.xaml under Window > preferences > Team > Jazz Source Control > File properties > text > xml. But it didn't change anything in the RTC change set view when we went back to the web interface. Would you expect this change to apply retrospectively or only for new files?

As for how they got set to binary, they were just added like that automatically when checked in.

I'll also see what happens if we set the type on the individual files.

Thanks for your help,

James

permanent link
Sreerupa Sen (1.0k4) | answered Jan 12 '11, 5:26 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
Hi, when you say you're using RTC VS Client, you're using that to check in files as well right? You mention a Web Client as well, so I'm wondering.
Could you look at the Visual Studio Properties View for the xaml file and check the MIME Type and Line Delimiter properties, under the Jazz Source Control section?
I'm a part of the VS Client development team and we use WPF extensively and have a whole lot of xaml files. I just checked the MIME Type and Line Delimiter properties for these files, which were set automatically for us when we checked in.
Line Delimiter None(Binary)
MIME Type application(unknown)
And the files compare just fine from within the VS Client. I tried it just now to reconfirm. Did you try from within the VS Client as well?

permanent link
Ralph Schoon (61.4k33643) | answered Jan 12 '11, 5:50 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
One more thing I tried out was changing the mime type to text/plain on an XAML file. Then the compare works in the web UI and the file can be browsed as well.

However, there seems to be no way to default the mime type of a file for Visual Studio.

Ralph


Hi, when you say you're using RTC VS Client, you're using that to check in files as well right? You mention a Web Client as well, so I'm wondering.
Could you look at the Visual Studio Properties View for the xaml file and check the MIME Type and Line Delimiter properties, under the Jazz Source Control section?
I'm a part of the VS Client development team and we use WPF extensively and have a whole lot of xaml files. I just checked the MIME Type and Line Delimiter properties for these files, which were set automatically for us when we checked in.
Line Delimiter None(Binary)
MIME Type application(unknown)
And the files compare just fine from within the VS Client. I tried it just now to reconfirm. Did you try from within the VS Client as well?

permanent link
James Clarke (21122) | answered Jan 14 '11, 6:10 a.m.
Yes we're using the visual studio client to do check-ins. When I say the web interface I mean the main set of RTC web pages.

Anyway, your suggestion on setting the MIME type worked : )

If I change Properties > File Properties :
MIME Type to text/plain
Line Delimiter to Platform

Then the diff view starts working!

Excellent, although obviously a default setting would be good. I'll dig around in VS and see if I can find anything. I didn't even know about the MIME type setting until now though so thanks for pointing me at that.

Thanks again for the help

Hi, when you say you're using RTC VS Client, you're using that to check in files as well right? You mention a Web Client as well, so I'm wondering.
Could you look at the Visual Studio Properties View for the xaml file and check the MIME Type and Line Delimiter properties, under the Jazz Source Control section?
I'm a part of the VS Client development team and we use WPF extensively and have a whole lot of xaml files. I just checked the MIME Type and Line Delimiter properties for these files, which were set automatically for us when we checked in.
Line Delimiter None(Binary)
MIME Type application(unknown)
And the files compare just fine from within the VS Client. I tried it just now to reconfirm. Did you try from within the VS Client as well?

permanent link
James Clarke (21122) | answered Jan 14 '11, 6:15 a.m.
@sreerupa
Just to answer your last question, the visual studio client compare always worked fine it was just the diff view in the main web interface that didn't work.

The reason I'm keen to get the web view working is that the change sets are linked from work items and you get a really nice 1 page summary of all the changes.

Yes we're using the visual studio client to do check-ins. When I say the web interface I mean the main set of RTC web pages.

Anyway, your suggestion on setting the MIME type worked : )

If I change Properties > File Properties :
MIME Type to text/plain
Line Delimiter to Platform

Then the diff view starts working!

Excellent, although obviously a default setting would be good. I'll dig around in VS and see if I can find anything. I didn't even know about the MIME type setting until now though so thanks for pointing me at that.

Thanks again for the help

Hi, when you say you're using RTC VS Client, you're using that to check in files as well right? You mention a Web Client as well, so I'm wondering.
Could you look at the Visual Studio Properties View for the xaml file and check the MIME Type and Line Delimiter properties, under the Jazz Source Control section?
I'm a part of the VS Client development team and we use WPF extensively and have a whole lot of xaml files. I just checked the MIME Type and Line Delimiter properties for these files, which were set automatically for us when we checked in.
Line Delimiter None(Binary)
MIME Type application(unknown)
And the files compare just fine from within the VS Client. I tried it just now to reconfirm. Did you try from within the VS Client as well?

permanent link
Ralph Schoon (61.4k33643) | answered Jan 14 '11, 9:51 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi James,

you might not find a way to do the default setting in Visual Studio. There is a mechanism built into our Eclipse Client but I couldn't find anything in Visual Studio. When I talked to @sreerupa she mentioned there where reasons in the Windows environment why the integration does set the mime type to application by default.

However, the reason you provide for why you would like to have it is reasonable at least to me. So you might want to consider to add an enhancement request so that we get it logged. Maybe there is a way to make it easier to support your use case.

Thanks,

Ralph

Yes we're using the visual studio client to do check-ins. When I say the web interface I mean the main set of RTC web pages.

Anyway, your suggestion on setting the MIME type worked : )

If I change Properties > File Properties :
MIME Type to text/plain
Line Delimiter to Platform

Then the diff view starts working!

Excellent, although obviously a default setting would be good. I'll dig around in VS and see if I can find anything. I didn't even know about the MIME type setting until now though so thanks for pointing me at that.

Thanks again for the help

Hi, when you say you're using RTC VS Client, you're using that to check in files as well right? You mention a Web Client as well, so I'm wondering.
Could you look at the Visual Studio Properties View for the xaml file and check the MIME Type and Line Delimiter properties, under the Jazz Source Control section?
I'm a part of the VS Client development team and we use WPF extensively and have a whole lot of xaml files. I just checked the MIME Type and Line Delimiter properties for these files, which were set automatically for us when we checked in.
Line Delimiter None(Binary)
MIME Type application(unknown)
And the files compare just fine from within the VS Client. I tried it just now to reconfirm. Did you try from within the VS Client as well?

permanent link
Terry Taylor (4199) | answered Jun 23 '11, 4:15 p.m.
However, the reason you provide for why you would like to have it is reasonable at least to me. So you might want to consider to add an enhancement request so that we get it logged. Maybe there is a way to make it easier to support your use case.


Has there been any progress on this? I came searching with exactly the same intent. The "all on one page" would be fantastic!

I also take it that this is a Visual Studio only problem, or more specifically a Visual Studio RTC Client problem on delivering a change set? I'm on a beta RTC 3 and haven't upgraded to 3.0.1 yet though...

Cheers

Tel

permanent link
Judith Steen (6) | answered Sep 30 '11, 2:27 p.m.
You could multi-select the files in the Solution Explorer and choose the Jazz Properties menu option. That brings up a single Jazz properties dialog where you can change the MIME type of multiple files.
The Jazz Properties dialog if opened for multiple files will show only properties that are the same across all files - say maybe repository URL, component etc. If the files have different MIME types, it will display a blank for the for MIME type property value, but if you then set it to a specific value the VS Client will set it across all the files you selected.


Cheers,
Rupa


Thank you! That explained the process for me...and now I think Ive got it.

Your answer


Register or to post your answer.