It's all about the answers!

Ask a question

Jazz RSS feeds from jazz.net


Milan Krivic (98012176142) | asked Dec 21 '10, 10:05 a.m.
Hi,

When I start my jazz team server everything works well except Jazz News viewlet. I got these messages:

There was a problem loading the feed:
The content was not a recognized feed.

It seems that we have some proxy limitations. What should I need to do to get this feature about Jazz News at my jazz team server?
How can I setup proxy settings at my jazz team server for enabling this?

Any help? Suggestions?

Regards,

14 answers



permanent link
ryosuke oka (17994648) | answered Mar 23 '11, 3:45 a.m.
Hi,

I had a smilar issue with
- RSS feeds
- Open Social gadget
- Help file

the cause of the issue was the setting of Tomcat server.
Once I set following entries in catalina.properties.
Then the issue of RSS feeds and Help file was solved.

However, OpenSocial gadget is still having the issue.
I used a google calender site for this.

Dose anyone know why the behaviour of OpenSocila gadget is different from others?


Addint these Enteries in catalina.properties:
http.proxyHost=yourProxyURL
http.proxyPort=yourProxyPort
http.proxyUser=yourUserName
http.proxyPassword=yourPassword

permanent link
Janko Maksic (633) | answered Dec 22 '10, 9:48 a.m.
Any updates about this? I would also like to know how to configure JAZZ to use proxy server.

permanent link
Curtis d'Entremont (1.3k3) | answered Jan 14 '11, 12:16 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
Can you provide the URL of the feed you're trying to view? The news feed viewlet doesn't support authentication in general, so it won't work for protected feeds. Also, the feed XML can accidentally be corrupt if edited by manual users.

permanent link
Julian Jones (463) | answered Jan 14 '11, 6:06 p.m.
JAZZ DEVELOPER
I use the following feed from jazz.net for the Jazz News content:

http://jazz.net/pub/community/news/feed.rss?externalize=true

Should you be interested, to track the jazz.net newsgroups I use: https://jazz.net/forums/rss.php

And to follow changes on the jazz.net wiki I use: https://jazz.net/wiki/bin/view/Main/WebRss

permanent link
Curtis d'Entremont (1.3k3) | answered Jan 17 '11, 11:05 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
The first two feeds listed above currently work, but the 3rd one doesn't because it requires authentication.

Milan, Is this the feed you were trying to use?

permanent link
Benjamin Chodroff (8985231) | answered Jan 17 '11, 12:50 p.m.
How to configure Jazz to use a proxy server -- I'm not positive if this will work, but give it a shot. Please let us know if it works -- we should definitely document this!

Create a new text file org.eclipse.core.net.prefs in a Jazz server folder, depending on application server type:

For Apache Tomcat: JazzInstallDir/server/tomcat/work/Catalina/localhost/jazz/eclipse/workspace/.metadata/
.plugins/org.eclipse.core.runtime/.settings/

For IBM WebSphere Application Server: WASInstallDir/profiles/profile/temp/node/server1/jazz_war/jazz.war/eclipse/workspace/.metadata/
.plugins/org.eclipse.core.runtime/.settings/

Paste the following contents to org.eclipse.core.net.prefs and edit it according to you proxy configuration:

# General proxy settings
org.eclipse.core.net.hasMigrated=true
eclipse.preferences.version=1
proxiesEnabled=true
# HTTP proxy settings
# proxyData/HTTP/host=<proxy>
# proxyData/HTTP/port=<proxy>
# proxyData/HTTP/hasAuth=false
# HTTPS proxy settings
proxyData/HTTPS/host=<proxy>
proxyData/HTTPS/port=<proxy>
proxyData/HTTPS/hasAuth=false
# Hosts that will not use proxy
# nonProxiedHosts=<hostname1>
nonProxiedHosts=127.0.0.1|localhost


Restart the Jazz Team Server.

permanent link
Milan Krivic (98012176142) | answered Feb 08 '11, 9:51 a.m.
How to configure Jazz to use a proxy server -- I'm not positive if this will work, but give it a shot. Please let us know if it works -- we should definitely document this!

Create a new text file org.eclipse.core.net.prefs in a Jazz server folder, depending on application server type:

For Apache Tomcat: JazzInstallDir/server/tomcat/work/Catalina/localhost/jazz/eclipse/workspace/.metadata/
.plugins/org.eclipse.core.runtime/.settings/

For IBM WebSphere Application Server: WASInstallDir/profiles/profile/temp/node/server1/jazz_war/jazz.war/eclipse/workspace/.metadata/
.plugins/org.eclipse.core.runtime/.settings/

Paste the following contents to org.eclipse.core.net.prefs and edit it according to you proxy configuration:

# General proxy settings
org.eclipse.core.net.hasMigrated=true
eclipse.preferences.version=1
proxiesEnabled=true
# HTTP proxy settings
# proxyData/HTTP/host=<proxy>
# proxyData/HTTP/port=<proxy>
# proxyData/HTTP/hasAuth=false
# HTTPS proxy settings
proxyData/HTTPS/host=<proxy>
proxyData/HTTPS/port=<proxy>
proxyData/HTTPS/hasAuth=false
# Hosts that will not use proxy
# nonProxiedHosts=<hostname1>
nonProxiedHosts=127.0.0.1|localhost


Restart the Jazz Team Server.


hi benjamin,

this didn't work. I did everything what you told, but didn't work.

Any other suggestion?

permanent link
Steve Harris (101187) | answered Mar 03 '11, 9:19 a.m.
I want a suggestion about this too.

permanent link
Bjorn Baker (106) | answered Mar 03 '11, 9:39 a.m.
I want a suggestion about this too.


What kind of suggestion you want? ^_^

permanent link
Steve Harris (101187) | answered Mar 03 '11, 10:01 a.m.
I want a suggestion about this too.


What kind of suggestion you want? ^_^

What I want to know is how to make Jazz server pass though proxy server.

According to Milanm, following way did not work right?


------------------------------------------------------------------------------------
Paste the following contents to org.eclipse.core.net.prefs and edit it according to you proxy configuration:

# General proxy settings
org.eclipse.core.net.hasMigrated=true
eclipse.preferences.version=1
proxiesEnabled=true
# HTTP proxy settings
# proxyData/HTTP/host=<proxy>
# proxyData/HTTP/port=<proxy>
# proxyData/HTTP/hasAuth=false
# HTTPS proxy settings
proxyData/HTTPS/host=<proxy>
proxyData/HTTPS/port=<proxy>
proxyData/HTTPS/hasAuth=false
# Hosts that will not use proxy
# nonProxiedHosts=<hostname1>
nonProxiedHosts=127.0.0.1|localhost
------------------------------------------------------------------------------------

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.