It's all about the answers!

Ask a question

RTC V3 M7a - SDK Setup


Pat McCarthy (12152) | asked Aug 05 '10, 2:54 p.m.
JAZZ DEVELOPER
I took a very light approach to my first interaction with RTC V3 M7a. I just wanted to see how my code held together on the V3 platform.

I unzipped the RTC only server and unzipped the RTC V3 Eclipse IDE client.

I could compile my examples that use RTC client side plugins, but not server side plugins.

I looked a the pde/target platform options and saw that there were some targets for RTC SDK, but they assumed that I had used Installation Manager to install the client and/or server code.

I could not find any RTC source given my unzip RTC Client.

Is this the new way to consume the SDK (Installation Manager install only?)

Will there be an unzip and go option for RTC V3 SDK?

Am I missing something?

3 answers



permanent link
Pat McCarthy (12152) | answered Aug 10 '10, 2:06 p.m.
JAZZ DEVELOPER
When I moved old project to my new RTC I endedup with a project where I had once played with PDE targets to help make the SDK setup easier a while back.

Those were what I saw in my unzipped RTC V3. So both are equal, the IMgr installed RTC Eclipse Client and the unzipped RTC Eclipse Client.

Where are the Source and JUnit downloads we have seen in the past?

So far I've been able to check some of my client side examples, but not the server side yet. I'm going to try some old techniques of pointing the target platform to the server directory tree after the starting the server.

But, without the source, it will be very hard to do much (as we use it for both compile and the Javadoc).

Are these downloads caught up in some approval process?

permanent link
Pat McCarthy (12152) | answered Aug 11 '10, 11:17 a.m.
JAZZ DEVELOPER
Figured out something that works, but it needs a bit of a kick start (imported plugin) to complete the compile of my samples.

The PDE target definition below assumes that you have used Installation Manager to install:
- RTC Eclipse Client
- Team Concert - Jazz Team Server
- RTC Build Engine/Toolkit

It may have more locations than it really needs, but it works for me now.

It did not support all my samples until I did two things:
- define the preference - Run/Debug>String Substitution value for RTC_Install_Dir (my ${RTC_Install_Dir} = E:\jazz_v3\rtc)
- make the target below active
- import the com.ibm.team.repository.services plugin using the plugins view.

The last item was odd; the plugin was in the view, so part of the target, but not visible to my code (imports did not resolve). I did a binary import and things got better/all my code compiled unchanged.

No errors for the most part - some deep SCM File System plugin code refs are broken, but that was not a big surprise (filesystem API there is evolving).

My Target; includes build, you may want to delete those refs.

<xml>
<pde>

<target>
<locations>
<location>
<location>
<location>
<location>
<location>
<location>
<location>
</locations>
</target>

permanent link
Pat McCarthy (12152) | answered Aug 11 '10, 1:06 p.m.
JAZZ DEVELOPER
Not sure why the target file xml won't show - I could see it in preview after I clicked the "Disable HTML in this post" toggle.

Trying again; Content:

<?xml version="1.0" encoding="UTF-8"?>
<?pde version="3.5"?>

<target name="RTC SDK V3 with Build Target - Relative">
<locations>
<location path="${eclipse_home}" type="Profile"/>
<location path="${RTC_Install_Dir}\TeamConcertBuild\buildengine\eclipse\plugins" type="Directory"/>
<location path="${RTC_Install_Dir}\TeamConcertBuild\buildtoolkit" type="Directory"/>
<location path="${RTC_Install_Dir}\JazzTeamServer\server\conf\jazz\sites\update-site\plugins" type="Directory"/>
<location path="${RTC_Install_Dir}\JazzTeamServer\server\conf\rtc\sites\rtc-commons-update-site\plugins" type="Directory"/>
<location path="${RTC_Install_Dir}\JazzTeamServer\server\conf\rtc\sites\update-site\plugins" type="Directory"/>
<location path="${RTC_Install_Dir}\JazzTeamServer\server\tomcat\webapps\jazz\WEB-INF\eclipse\plugins" type="Directory"/>
</locations>
</target>

Your answer


Register or to post your answer.