It's all about the answers!

Ask a question

Storing Word Documents using Web Client


Rob Logie (33825041) | asked May 25 '10, 10:18 p.m.
Hi
We are using RTC 2.0.0.2 to store and version manage MS Word document using the web client.

However, when we view the history of a word document we are getting a binary difference, which is useless. It looks like this:

http://i1015.photobucket.com/albums/af271/rob_at_work/ScreenShots/Andrew1.jpg

Also, if you press "Before" on the window above, you get this window displayed, giving a binary line by line comparison of the word document, which is again useless and confusing to some users:

http://i1015.photobucket.com/albums/af271/rob_at_work/ScreenShots/Andrew2.jpg

Is there a way to configure RTC so it either displays the word document correctly in the web client (or calls word on the the browser is running on ). Alternatively can it be configured not to display the binary contents at all ?


Thanks in Advance

Rob

6 answers



permanent link
Rob Logie (33825041) | answered May 31 '10, 1:58 a.m.
Any ideas anyone ?


Thanks

permanent link
Ralph Schoon (60.9k33643) | answered May 31 '10, 4:42 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi,

I use RTC 2.0.0.2 IFix 2.

In the overview I am told "Unable to show file as its content is not text."
In the history I don't get the compare, instead I get only the changes.
* <No>Jerry Jazz May 31, 2010 10:26 a.m. (2 minutes ago)
* <No>Jerry Jazz May 31, 2010 10:25 a.m. (3 minutes ago)

I am not sure what causes the behavior on your system. I assume somehow the file is interpreted as being a text file.

I'd try to change the file type. I guess somehow it is set to text.
To change that, load the stream into a repository workspace. In eclipse e.g. the navigator right-click the file and open the properties. Check the mime type. It should be application/msword.

Pleas also check your settings in the eclipse client. in Window>Preferences>Team>Jazz Source Control>File Properties
I think there should be an entry "Word document" for the extension *.doc

Just my best guess,

Ralph

Any ideas anyone ?


Thanks

permanent link
Rob Logie (33825041) | answered Jun 01 '10, 8:30 p.m.
Hi Ralph,
I have checked the Mime type and it is application/msword

BTW, the version I am using is

Jazz Foundation - Jazz Team Server 1.0.0.2 iFix 1 I20100302-1947
Rational Team Concert 2.0.0.2 iFix 1 I20100302-1947

Thanks

Rob

Hi,

I use RTC 2.0.0.2 IFix 2.

In the overview I am told "Unable to show file as its content is not text."
In the history I don't get the compare, instead I get only the changes.
* <No>Jerry Jazz May 31, 2010 10:26 a.m. (2 minutes ago)
* <No>Jerry Jazz May 31, 2010 10:25 a.m. (3 minutes ago)

I am not sure what causes the behavior on your system. I assume somehow the file is interpreted as being a text file.

I'd try to change the file type. I guess somehow it is set to text.
To change that, load the stream into a repository workspace. In eclipse e.g. the navigator right-click the file and open the properties. Check the mime type. It should be application/msword.

Pleas also check your settings in the eclipse client. in Window>Preferences>Team>Jazz Source Control>File Properties
I think there should be an entry "Word document" for the extension *.doc

Just my best guess,

Ralph

Any ideas anyone ?


Thanks

permanent link
Rob Logie (33825041) | answered Aug 24 '10, 7:03 p.m.
Bump...
Has anyone got any ideas on how to resolve issue ?


Thanks

Rob

Hi Ralph,
I have checked the Mime type and it is application/msword

BTW, the version I am using is

Jazz Foundation - Jazz Team Server 1.0.0.2 iFix 1 I20100302-1947
Rational Team Concert 2.0.0.2 iFix 1 I20100302-1947

Thanks

Rob

Hi,

I use RTC 2.0.0.2 IFix 2.

In the overview I am told "Unable to show file as its content is not text."
In the history I don't get the compare, instead I get only the changes.
* <No>Jerry Jazz May 31, 2010 10:26 a.m. (2 minutes ago)
* <No>Jerry Jazz May 31, 2010 10:25 a.m. (3 minutes ago)

I am not sure what causes the behavior on your system. I assume somehow the file is interpreted as being a text file.

I'd try to change the file type. I guess somehow it is set to text.
To change that, load the stream into a repository workspace. In eclipse e.g. the navigator right-click the file and open the properties. Check the mime type. It should be application/msword.

Pleas also check your settings in the eclipse client. in Window>Preferences>Team>Jazz Source Control>File Properties
I think there should be an entry "Word document" for the extension *.doc

Just my best guess,

Ralph

Any ideas anyone ?


Thanks

permanent link
Anthony Kesterton (7.5k7178136) | answered Aug 25 '10, 6:51 a.m.
JAZZ DEVELOPER
Bump...
Has anyone got any ideas on how to resolve issue ?


Thanks

Rob


I realize this might not be the most useful suggestion - but Ralph has iFix2 - maybe that made the different. You seem to be on ifix3.

If you can't upgrade - raise a defect here on jazz.net in case there is something else that can be done.

regards

anthony

permanent link
Jean-Michel Lemieux (2.5k11) | answered Aug 25 '10, 11:05 a.m.
JAZZ DEVELOPER
We currently don't support showing word files in the web when showing the diffs as we don't have a diff viewer for the web. However, when you click that download button if your browser supports it, MS Word should open.

Your answer


Register or to post your answer.