It's all about the answers!

Ask a question

Illegal Argument Exception : in getItemType

Senthil Mani (122) | asked Mar 26 '10, 3:17 a.m.
We had ecore model based Jazz Component which we migrated from RTC 1. to RTC We created the DB (Derby) and ran our application. The application worked fine accessing the DB. After a couple of restart of the server, suddenly, no calls to DB work. We end up getting this kind of error.

java.lang.IllegalArgumentException: The type name Glossary and the namespace URI do not resolve to an IItemType.

Where, the "Glossary" is the Eclassifier name and is the nsURI.

When we tried this in debug mode, The EPackage corresponding to this artifact is coming as null - and hence this issue being reported.

What we are not able to understand is - the DB seems to be working fine - and all of a sudden this error starts coming up.

Once we delete the db and recreate it again, things all work fine for some time -- and after a couple of restart to the server, this issue again comes up.

Can anyone help us here to understand whats happening.

Be the first one to answer this question!

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.