It's all about the answers!

Ask a question

Disable security certificate settings, 500 Error


Lin Ye (30632611) | asked Jan 18 '10, 4:34 p.m.
Hi,

We are using RTC 2.0.0.2 standard edition. We disabled security certificate settings according to:
http://publib.boulder.ibm.com/infocenter/rtc/v2r0m0/topic/com.ibm.team.install.doc/topics/t_disable_server_certificates.html

It's alright to access the team server (not localhost) from http://servername:9080/jazz. The problem is if I log out and let the browser stand by. After a while such as 1 hour, when I try to refresh or revisit http://servername:9080/jazz, I got 500 error:
java.lang.IllegalStateException
org.apache.catalina.connector.ResponseFacade.sendRedirect(ResponseFacade.java:433)
com.ibm.team.repository.servlet.AbstractTeamServerServlet.handleRequest2(AbstractTeamServerServlet.java:1657)
com.ibm.team.repository.servlet.AbstractTeamServerServlet.handleRequest(AbstractTeamServerServlet.java:1623)
com.ibm.team.repository.servlet.AbstractTeamServerServlet.service(AbstractTeamServerServlet.java:1536)
javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
org.eclipse.equinox.http.registry.internal.ServletManager$ServletWrapper.service(ServletManager.java:180)
org.eclipse.equinox.http.servlet.internal.ServletRegistration.handleRequest(ServletRegistration.java:90)
org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:111)
org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:59)
javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
org.eclipse.equinox.servletbridge.BridgeServlet.service(BridgeServlet.java:121)
com.ibm.team.repository.server.servletbridge.JazzServlet.service(JazzServlet.java:54)
javax.servlet.http.HttpServlet.service(HttpServlet.java:803)


The exceptions are not printed on console or server's log. If I close the browser and start a new window, then everything works fine. Anything is wrong here? Thank you very much.

Lin

2 answers



permanent link
Lin Ye (30632611) | answered Jan 19 '10, 1:17 p.m.
Another issue is sometimes when I log in through http://servername:9080/jazz, the "Log out" button is missing. We are using IE7.

permanent link
Lin Ye (30632611) | answered Jan 19 '10, 5:02 p.m.
I am sorry that is my machine's problem.

Your answer


Register or to post your answer.