It's all about the answers!

Ask a question

Quick syntax Query is not working with default value "Unassigned" for RTC Plan

Rajat Krishnan (7012) | asked Sep 21, 3:07 a.m.
My usecase is i want to color code(with red color) workitem (if the planned for value is unassigned) now problem is Unassigned is by default value coming from IBM, and when we try to create query it does not work, i tried all the possible combiation stated below
  • plannedFor:""
  • plannedFor:"--"
  • plannedFor:"Unassigned"
But nothing works, can you please let me know what is the correct query i shall pass to achieve my usecase

Thank you

One answer

permanent link
Ralph Schoon (62.7k33643) | answered Sep 21, 4:42 a.m.

 When you edit the quick syntax, you can use CTRL+SPACE to get the possible values for e.g. plannedFor: in this context.

You might notice that none of the options you tried is in the list of allowed values. You can only select a valid iteration. So this is not supported. You can create an idea to get that changed. 
Or you create a plan view that shows the unassigned items in their own section. 

Rajat Krishnan commented Sep 21, 6:49 a.m.

you create a plan view that shows the unassigned items in their own section --> What if story is linked with a children task and task value is unassigned and story has some iteration 1.0 set and user want to see all the workitem along with link then this will not work for him

Ralph Schoon commented Sep 21, 7:59 a.m.

If you view by iteration, I think you see the parent as outplaced item - grayed out - if it is planned for the same iteration. 

Maybe try a query or report in the dashboard, if possible?

I think there also some new boards that show inconsistent iteration planning. Not sure. 

I would agree that your use case would be nice. There is and will always be something someone wants to do, that is not supported.     

Your answer

Register or to post your answer.