It's all about the answers!

Ask a question

Unable to Fetch TCERs assigned to a specific owner using ETM REST API

Jitesh Saha (177) | asked Apr 13 '22, 8:05 a.m.

we are trying to fetch all the Testcase Execution records assgined a specific owner using REST APIs but I am unable to do so.

So far we have tried the following URLs with both url encoded and unencoded format for the 'fields' part:
  • https://<ServerUrl>/qm/service/<ProjectAlias>/executionworkitem?feed/entry/content/executionworkitem/owner[@resource="<MemberID>"]
  • https://<ServerUrl>/qm/service/<ProjectAlias>/executionworkitem?feed/entry/content/executionworkitem[owner='<MemberID>]/*
  • https://<ServerUrl>/qm/service/<ProjectAlias>/executionworkitem?feed/entry/content/executionworkitem[owner/@resource="<ServerUrl>/jts/resource/itemName/<MemberID>"]

Any leads on what we are doing incorrectly here and the real solution would be much appreciated.

Thanks !!!

Jitesh Saha commented Apr 13 '22, 8:23 a.m. | edited Apr 13 '22, 10:04 a.m.

Update: I tried with Project Area OSLC ID instead of Alias Name as's still no good.

Accepted answer

permanent link
Stefan Schmelz (471619) | answered Apr 13 '22, 9:34 a.m.
edited Apr 13 '22, 9:51 a.m.
Jitesh Saha selected this answer as the correct answer

Stefan Schmelz commented Apr 13 '22, 9:50 a.m. | edited Apr 13 '22, 9:51 a.m.

Needed to edit the html...

Jitesh Saha commented Apr 14 '22, 12:52 a.m.
Hi Stefan,

This works excatly as expected. Thanks a lot for the answer !!!

Your answer

Register or to post your answer.