It's all about the answers!

Ask a question

[DNG] Module Explorer Widget is not working in ELM 702 iFix003


Chandan M B (1133474) | asked Nov 10 '21, 4:49 a.m.

Hello, 


Module explorer shows up as follows in Chrome 

Only show headings 
Turn off wrapping
colour by status
collapse at level 

instead of displaying the tree hierarchy.

What is the solution for this issue ?
I have referred this. 

I am not able to see the settings in JTS advanced properties
Could somebody help me out here

Regards,
Chandan


Comments
David Honey commented Nov 10 '21, 9:35 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Have you tried other web browsers to see if this is specific to Chrome?


1
Ian Barnard commented Nov 11 '21, 8:34 a.m. | edited Nov 11 '21, 8:36 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

There was a security tightening against SSRF in 7.0.2 iFix004 - the tightening means for 7.0.2 >=iFix004 by default extensions won't work until you've made a setting as described in this technote which also details of the other versions+ifixes this applies to (and 7.0 >=iFix008) see https://www.ibm.com/support/pages/node/6466981


You're using iFix003 so that isn't the problem you're having, and you don't see the setting because it was introduced in 004.


Edward Chan commented Aug 08 '23, 7:08 p.m. | edited Aug 08 '23, 7:08 p.m.

We see the same problem even in 2023. It works in Firefox but doesn't work in Edge. We followed https://www.ibm.com/support/pages/node/6466981 so this is not the issue. We can see the widget, it just seems the javascript doesn't work anymore on Chrome and Edge. What is the status and will these sample extensions ever be fixed?


Edward Chan commented Aug 08 '23, 7:09 p.m. | edited Aug 08 '23, 7:09 p.m.

Additionally I get the same problem with the Github extensions – in Chrome, they show some of the extension text. In Firefox, they work fine.

One answer



permanent link
Edward Chan (553) | answered Aug 27 '23, 9:10 p.m.

Hi I managed to solve this - we were using IHS Websphere to reverse proxy all the Jazz applications, and Chrome/Edge does not support self-signed certificates served directly from the Jazz application folders. So you cannot follow the instructions to copy the extensions to war/extensions.


Instead I copied the extensions to /export/IBM/HTTPServer/htdocs/jazz_extensions so that Websphere would serve the files directly to https://jazz:443/jazz_extensions

After updating all the whitelists etc, I can access the widgets from Firefox, Edge, and Chrome.

Basically the documentation needs to be updated to reflect that war/extensions probably won't work anymore unless you're using Firefox.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.