It's all about the answers!

Ask a question

RQM Command Line Adapter fails to connect to project area


Frank Hufnagel (111) | asked May 20, 7:58 a.m.
edited May 22, 1:39 p.m. by Geoffrey Clemm (29.8k23035)
Hi folks,

after a couple of days i wanted to use RQM CLA again, the days before it worked without any problems.

Now i cant connect to my project area anymore i get the following messages:

"The adapter is now connected
Unable to find project areaGET [403] : <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">"
...
html xmlns="http://www.w3.org/1999/xhtml">
<head>
  <title>Jazz - Permission Denied</title>
  <link type="text/css" rel="stylesheet" href="/qm/web/jazz.app/internal/templates/StaticLoginWidget.css"/>
</head>
<body>
  <h2>Permission Denied</h2>
  <div>Your account does not have the group memberships required to access the requested resource.</div>
</body>
</html>

Error while retrieving the list of project areas"

I dont understand why i am getting now 403 Forbidden for accessing the project Area. I changed nothing in config.
I checked my account at CoC, nothing has changed.
Role "JazzUsers" also existing.
Tried to change adapterId in Config2.ini, had no positive effect.
Logging into project area with Firefox also no problem.

Any suggestions how to solve this problem?

Kind regards
Frank

Comments
Ralph Schoon commented May 20, 9:10 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

This error can also happen in the RQM API for some reasons. See the answer on the post below. I have no idea how that could happen otherwise.  


2 answers




permanent link
Frank Hufnagel (111) | answered May 26, 3:41 a.m.
Thank your for the replies. I checked the previous answers but could not help.

The problem is now solved, the DevOps CoC Team imported a wrong licencse by mistake (v5 instead of v6). Now the CLA works again as expected.

Kind regards
Frank

Your answer


Register or to post your answer.