It's all about the answers!

Ask a question

[RQM Rest API] manual test result is missing node starttime in xml


Dani Simon (705) | asked Oct 12 '20, 5:18 a.m.
edited Oct 15 '20, 5:09 a.m.

  Hi


We updated our Jazz server to 7.0.1.
While we create the test result manually and get the execution result by Rest API afterwards, we miss the stepResult node "starttime" in xml. 

We use this request to get the execution result:

And in the result the step contains the endtime, but no starttime. Did RQM already behave this way before version 7.0.1?  
Is there a workaround to get still the starttime node in xml? 

If the execution result is created by Rest API, the ns16:stepResult contains both:

 <ns16:startTime>2020-10-12T06:47:43.739Z</ns16:startTime>
 <ns16:endTime>2020-10-12T06:48:08.176Z</ns16:endTime>

thanks a lot,
Dani

Accepted answer


permanent link
Donat Hutter (2153039) | answered Oct 22 '20, 4:43 p.m.

Hi Dani,
I observe this behavior if I run a test case execution record (TCER) with the option "Create a Result without Execution" and in the next step choose "create step results".


regards - Donat

Dani Simon selected this answer as the correct answer

One other answer



permanent link
Monika Rajput (2412) | answered Oct 21 '20, 9:59 a.m.

 Hi Dani,


I have tried the scenario but I could not see such issue. The starttime node for ns16:stepResult is there in the retrieved xml. 
If you need further investigation on this, please work with support. 
You can open a support case here: https://www.ibm.com/mysupport/s/?language=en_US

Thanks

Your answer


Register or to post your answer.