It's all about the answers!

Ask a question

Unable to generate ELO - Publishing reports against IBM Cloud instances


Matt Mendell (203) | asked Apr 22 '20, 7:22 p.m.

 Hello,


It seems that I am unable to generate any RPE/ELO - Publishing reports against IBM Cloud -hosted applications.

In the simplest example, in our locally hosted instance of the application I can go into ERM - DOORS Next, browse to a module, drag the link for the module into the Document Studio window and have the application generate a template for me (using the 'Create a new template for the web resource URL' option). When I do these same steps for an application on IBM SaaS, I just get a message saying 'Connection failed'.

What I actually want to do is run a more complex template of my own creation against ERM and ETM hosted on IBM SaaS, but each time I go to do this I get the same issue. I thought it might be the authentication method that is different, but I have cycled through each of those options and the results are the same.

Are there any different ways that the URL needs to be transformed when reporting from IBM Cloud? Is there some other option that needs to be changed when I generate the report? Any advice on things I should check would be greatly appreciated.

Thanks in advance,

Matt

Accepted answer


permanent link
Davyd Norris (1.7k12) | answered Apr 22 '20, 8:39 p.m.
The Cloud hosted instances have their security configuration set higher than the default installs and so any clients need to connect with TLS 1.2. This includes the command line utilities, EMW Clients and ELO Publishing.

To set ELO Publishing to connect at this higher security, you have to add a line to the Document Studio and Document Launcher ini files. Open the files:
<installation dir>\studio\rpe-studio.ini
and
<installation dir>\launcher\rpe-launcher.ini

and add the line:
-Dcom.ibm.rational.rpe.tls12only=true

to the end. Depending on where you installed these, you may need to start Notepad as Admin.

This won't affect your local connection but it will enable you to connect to the Cloud instances

Matt Mendell selected this answer as the correct answer

Comments
Matt Mendell commented Apr 23 '20, 4:12 a.m.

Thank you very much for the clear instructions Davyd. This worked for me. 

Your answer


Register or to post your answer.