It's all about the answers!

Ask a question

Automated removal of artifacts are not removed completely from a module.


Kenieth Buyuccan (11) | asked Apr 03 '20, 4:19 p.m.

I removed some artifacts from a module then I duplicated the artifacts in a separate module; however, the artifacts that were removed from the original module showed up in the new module. I also noticed that the "Section" attribute does not adjust in the original module. Below is the process:

1. Exported the module to an excel file

2. The artifacts for removal were deleted from the excel file

3. Imported the updated excel file back to DOORS using the "Import requirements into a module" and selecting the " Delete artifacts from the module which have been removed from the exported file"

In contrary, if I use the conventional way of removing an artifact from a module, the removed artifact do not show up in the new module when duplicated. Also, the "Section" attribute re-adjust so the numbering is sequential.

 

One answer



permanent link
Diana Kraaijeveld (44227) | answered Apr 06 '20, 4:31 a.m.
JAZZ DEVELOPER
Hi Kenieth,

I did a quick test in version 6061-Ifix008 but could not reproduce the problem you describe.
- What version and Ifix version of DNG did you use exactly?
- When you duplicated the module, what options did you choose (ie 're-use existing artifacts' or 'duplicate all artifacts')?
- Did you keep or remove the Metadata section from the excel sheet?

It may be a good idea to report this problem with support, with the exact steps and version used, so they can try to reproduce and make sure the problem gets reported with development and fixed in an upcoming version, if applicable.

Your answer


Register or to post your answer.