It's all about the answers!

Ask a question

RQM REST API 403 error "Edit section header" permission

Luke Locastro (112) | asked Feb 20 '20, 7:19 a.m.

I'm currently able to edit execution results using the rest api with no errors, I want to edit some test cases but I get a 403 error that says

Save Test Case Failed You don't have permission to perform the following actions:
  Edit Section Header (edit section header)

I have permission to create and edit test cases but not to Edit Section Header
I get the error even when sending a unedited xml of an existing test case by performing a GET then PUT to the same address without changing the xml

the issue seems to be the same as this
but the server I am working on is running version 6.0.5

Ara Masrof commented Feb 20 '20, 8:47 a.m.
To be clear:
You are able to perform a GET (REST API) on a Test case and use the corresponding Response Data in a PUT and you get the error?
Do you have XML Import POST permissions set?

Luke Locastro commented Feb 20 '20, 8:56 a.m. | edited Feb 20 '20, 8:58 a.m.


Luke Locastro commented Feb 20 '20, 8:57 a.m.

Yes I perform the GET then use the response data in PUT without changing and get the error, I also tried removing the read only elements but got the same error

My account has the XML XML Import POST and delete permission

I just tried performing the PUT with a colleague's account who has Edit Section Header permission and it works as expected with no errors

But as i'm not making any changes to the xml I thought I should be able to perform the PUT without this permission 

One answer

permanent link
Jim Ruehlin (79114) | answered Feb 20 '20, 5:13 p.m.

 You might not have permission to update the information in the project. When you use the API you still have the same role constraints as when you use the UI. If you colleague can make the changes but you can't, it's possible he/she has a role in the project that allows the update and you don't have the same role.

Luke Locastro commented Feb 26 '20, 11:07 a.m.

 I have found what's causing the permission issue, I'm able to make the changes I want in the UI but not over the API

when using the API to upload the XML it is attempting to change the name of the Test Case Design section header of the test case, in the UI this has been set to "Test Steps"

The XML contains this element
< xmlns="" extensionDisplayName="Test Steps"><div xmlns="">1.Check for icon in the side bar of the screen </div></>

When I uploaded this XML using my colleagues account it was changing the section name without me noticing hence why it would only with his account permissions and not mine

Even if I use the RQM URL utility to download and upload the same XML file it is attempting to change this section header?

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.