It's all about the answers!

Ask a question

Sharing views with new modules added


Kim Boshers (634) | asked Jan 28 '20, 10:21 a.m.

In testing of migration:  I created views after migrating some modules over and set which Teams should have access to it.  When I migrate or create new modules with the same Team, why don't the views share with those newly created modules that are with that same Team?

2 answers



permanent link
Sean F (1.3k22669) | answered Jan 28 '20, 10:52 a.m.

Hi Kim,

Did you select 'Shared' when you saved your view?

Did you select 'All modules of this type' when you saved your view?


If so then are the new modules you are creating of the same type as the one for which you created the original view?

If so then the view should be available in the new module.

If you alternatively selected 'All Modules' then the view should be available regardless of what type of module you create.


Comments
Kim Boshers commented Jan 28 '20, 12:50 p.m.

Yes, I did all of those things when trying to share the view with the new modules.  


In a recent test, I created a brand new view to share with all modules and didn't specify a team this time to share with, and it actually did share the view with all of the modules! ... But, it removed the other views I created from all the modules that originally had them!!  Now, I'm trying to figure out why that happened and how I can get them back.


permanent link
Kim Boshers (634) | answered Jan 28 '20, 5:49 p.m.
edited Jan 28 '20, 5:50 p.m.

I just tried this in the Sandbox with the "Test Coverage"  view from the AMR System Requirements module.  I added two new modules, set the team ownership to be the same, but still the "Test Coverage" view will not share to the new modules added.


When I create a new view and define the settings, it works fine across all the modules.  As soon as it becomes an existing view, it won't share for my new modules, and I don't have the same options to edit for sharing across all modules as the options available when I am creating a new view.  

Note: I did change the module type after I migrated, thinking that the view could be assigned if it had the same module type defined in the "Test Coverage" view.  That could be the issue, I guess.

Testing with sharing with all modules selected, no defined type, the shared view does automatically show up in my newly migrated module, and the other views didn't get removed this time!!

(I'd share some images, but I have less than 60 rep points)

Your answer


Register or to post your answer.