It's all about the answers!

Ask a question

OSLC Server - Friend (Outbound)


Michael Dahm (11) | asked Nov 01 '19, 10:34 a.m.

Hi everyone,

we are currently implementing our own OSLC-Server that shall be used together with the RTC.

The first step that we worked on is the registration of our server as a Friend (Outbound) in the RTC.

The RootServices of our server look like the following:

<?xml version="1.0" encoding="UTF-8"?>
<rdf:Description rdf:about="http://localhost:8080/adaptor-sample/rootservices"
                 xmlns:oslc="http://open-services.net/ns/core#"
                 xmlns:oslc_cm="http://open-services.net/xmlns/cm/1.0/"
                 xmlns:dcterms="http://purl.org/dc/terms/"
                 xmlns:jfs="http://jazz.net/xmlns/prod/jazz/jfs/1.0/"
                 xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
                 xmlns:jd="http://jazz.net/xmlns/prod/jazz/discovery/1.0/">    
    <dcterms:title>Root Services</dcterms:title>
    <oslc_cm:cmServiceProviders rdf:resource="http://localhost:8080/adaptor-sample/catalog" />
    <jfs:oauthRealmName>Server</jfs:oauthRealmName>
    <jfs:oauthDomain>http://localhost:8080/adaptor-sample/oauth</jfs:oauthDomain>
    <jfs:oauthRequestConsumerKeyUrl rdf:resource="http://localhost:8080/adaptor-sample/oauth/requestKey" />
    <jfs:oauthApprovalModuleUrl rdf:resource="http://localhost:8080/adaptor-sample/oauth/approveKey" />
    <jfs:oauthRequestTokenUrl rdf:resource="http://localhost:8080/adaptor-sample/oauth/requestToken" />
    <jfs:oauthUserAuthorizationUrl rdf:resource="http://localhost:8080/adaptor-sample/oauth/authorize" />
    <jfs:oauthAccessTokenUrl rdf:resource="http://localhost:8080/adaptor-sample/oauth/accessToken" />
</rdf:Description>

Afterwards we tried to associate our server with a project in the ccm domain. But in this step, an error occured.

The RTC tells us, that it has problems reading the rootservices of our server. The RTC could however read these rootservices when registering our server as a friend. I can not upload an image but the warning message says: Failed to read artifact container catalog resource:
Unable to load URL: /ccm/proxy?uri=http://localhost:8080/adaptor-sample/rootservices, Status: 500


After digging realy deep in the log-files I found the following log line:

2019-10-30 15:56:13,678 [Default Executor-thread-760 @@ 15:56 name <Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0@127.0.0.1> /ccm/proxy] DEBUG .internal.oauth.shared.AuthenticatingClientService  - The target of the outbound call is not a friend

So we assume that our server could not be registered as a friend completely in the RTC.

Can anybody suggest why the registration did not work and how to solve this problem?

Regards
Michael

Be the first one to answer this question!


Register or to post your answer.