It's all about the answers!

Ask a question

RPE unwanted page break before first heading in module


Sean F (1.1k12337) | asked Jun 08 '19, 2:23 p.m.

I am publishing 2 DNG modules using the same DTA for each module.

There are 2 template instances in the DSX. each one references the same DTA file.

The URI is different and each URI references its relevant module.

There is no stylesheet.

The default Heading 1 style does not have a page break before so the content of each module is published with no page breaks at all.

However RPE is inserting a single page break immediately before the first heading in the 2nd module.

Note that if the 2nd module contains some text objects before the first heading then these text objects appear before the page break.

i.e. the page break is before the 1st heading, not the 1st artifact.

Is this a bug?

Accepted answer


permanent link
Subramanya Prasad Pilar (3.7k14) | answered Jun 09 '19, 1:19 p.m.

Are you using master page in the template? I tried using sample template we are shipping with RPE, but I dont see the issue. Can you attach the template you are using?

Sean F selected this answer as the correct answer

4 other answers



permanent link
Subramanya Prasad Pilar (3.7k14) | answered Jun 09 '19, 4:45 a.m.
This should be as per the "Heading 1" style in your Word instance. Please check Heading 1 style in Word:
If you do not want page break before a Level 1 heading, change the Heading 1 style - uncheck "Page break before" under Format->Paragraph... Line and Page Breaks tab.


permanent link
Sean F (1.1k12337) | answered Jun 09 '19, 10:02 a.m.
Hi Prasad,

Thanks for your time.

No it is not to do with styles.

I know about setting the 'page break before' option in the stylesheet.

I can reproduce this problem using a stylesheet with heading styles set to have no 'page break before'.

I can also reproduce this problem using no stylesheet (i.e.the default styles in normal.dot - which again do not have page breaks on the headings).

The problem is specific to the first heading in the 2nd module (and subsequent modules)

The rest of the headings in the 1st and 2nd modules do not have page breaks. Only the 1st heading in the 2nd module.

permanent link
Sean F (1.1k12337) | answered Jun 09 '19, 10:27 a.m.
RPE 6.0.6
DNG 6.0.6 (iFix008)

permanent link
Sean F (1.1k12337) | answered Jun 09 '19, 2:34 p.m.
It must be the masterpage that is causing a page break before the first heading.

There is a masterpage in the template and it gets updated with a new header and footer (passed in as external variable parameters from the DSX) for each new module.

This is a problem since I need to be able to print a line of text above the first heading in the 2nd module (It is a section title which is not a numbered heading and not part of the numbered heading sequence) and then have the first heading in the 2nd module appear below this line of text on the same page with no page break but this does not seem to be possible.

Your answer


Register or to post your answer.