It's all about the answers!

Ask a question

Caching RTC SCM content via Caching Proxies


Arun K Sriramaiah (3.2k13477) | asked Jan 09 '19, 3:00 a.m.

Caching SCM content via Caching Proxies (Squid / Apache TrafficServer ) doesn't work if the caching proxy used is in another domain (as the AppServer) as the HTTP Header "Cache-Control: public, s-maxage=31104000, no-cache=set-cookie" is set which tells the proxy not to cache.

Accepted answer


permanent link
Arun K Sriramaiah (3.2k13477) | answered Jan 09 '19, 3:05 a.m.
edited Jan 09 '19, 3:45 a.m. by Ralph Schoon (63.3k33646)

The default for "CookiesConfigureNoCache" changed from False to True

Reason:

Users were encountering a number of OS and browser related HTTP headers handing issues and so on balance we changed the default.

  Hence "CookiesConfigureNoCache=false" works .

Ralph Schoon selected this answer as the correct answer

Comments
Ralph Schoon commented Jan 09 '19, 3:47 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I don't understand the answer. How does one detect the issue? Which server has the setting? Where does one have to set the setting? 

One other answer



permanent link
Todd Dunnavant (571019) | answered Oct 14 '21, 11:59 p.m.
Hi, Ralph, this is a WebSphere Application Server property, I don't know if it also applies to Liberty.

There most likely are a number of approaches for setting the property.  I found a number of instructional hits by performing a Google search on CookiesConfigureNoCache.

Comments
Ralph Schoon commented Oct 15 '21, 2:10 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Thanks. I have worked with customers that use different caching proxy products and the setup seems to be quite complex. 

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.