It's all about the answers!

Ask a question

Changing safe 4.5 beta to final


Norman Dignard (35045798) | asked Aug 22 '18, 12:26 p.m.
edited Sep 10 '18, 6:22 a.m. by Paul Slauenwhite (8.3k12)

Is there a method to update a project area using safe 4.5 beta to safe 4.5 final?

We had imported the beta templates onto our 6.0.5 testbed. Somewhere along the way they were put into our 605 production and 2 projects started using them.    The only issue users have reported is that the shared queries are not populated  and if you do create a shared query , it disappears. 

The projects want to have the shared query problem resolved first as that is a hindrance to their use.
The second part of this is to update the project to reflect whatever changes are needed to make them a final safe 4.5 implementation.  As i understand it from Amy, IBM's safe guru, you need 606 .  The problem here is we won't be upgrading for about another 6months of so.

Any insight welcome



Comments
Heather Linsk commented Aug 22 '18, 12:48 p.m.

I am having the same issues 


Dinesh Kumar commented Aug 24 '18, 4:56 a.m.
JAZZ DEVELOPER
HI Norman,

Switching a project area to a different template is through process inheritance and by pointing to a different parent project area.  Further, such a switch cannot be done with project areas from a different process template altogether. Given that background, I am afraid there may be no way to switch to SAFe Final from SAFe Beta.

Can you share what error/log is generated in ccm, when you attempt to view the shared queries. Have you been able to test SAFe Final templates, possibly on a different instance and does the shared queries work well there... If the same failure happens with SAFe Final project areas as well, we could assess further for a generic defect here based on what you see in the logs... 


Norman Dignard commented Aug 24 '18, 8:37 a.m.

Dinesh   I do not fully agree with you on process inheritence.  We have many PAs - none use process inheritance.  In our organization, we allow the flexibilty for each PA to adopt/customize their own processes to suit their needs.  While this may not be a recommended practice from a Corporate perspective (standarization, etc..) it is the way the organization wants it. IBM does provide docs on changing a scrum PA to Safe by modifying the PA process manually.

 A Safe 4.5beta instantiated PA does not have any Shared queries and there does not appear to be a way to add them even when creating a personal one then sharing it. When you do your query disappears. The only way to see it again is to unshare it.


Norman Dignard commented Aug 24 '18, 8:38 a.m.

 Dinesh - to continue onthe error:

For an error, get a popup "Error fetching queries null". CM log only shows this:
2018-08-24 08:26:14,176 [Default Executor-thread-443933 @@ 08:26 dignarn <Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36@192.168.102.13> /ccm/service/com.ibm.team.workitem.common.internal.rest.IQueryRestService/scopedQueries]  WARN .team.repository.servlet.AbstractTeamServerServlet  - CRJAZ1163E ArrayIndexOutOfBoundsException error occurred while processing a GET request for com.ibm.team.workitem.common.internal.rest.IQueryRestService.getScopedQueries(). CRJAZ1170I The request was made by user "dignarn" from "192.168.102.13".CRJAZ1167I The stack trace hash is C20A43971EA8E414D77D5C438CB5A50CF7812E71, use it to locate the previously logged stack trace at Fri Aug 24 08:25:37 EDT 2018.

One answer



permanent link
Amy Silberbauer (26657) | answered Sep 10 '18, 9:02 a.m.
JAZZ DEVELOPER
Hi all,
The issue with the queries existed in an early version of the Essential SAFe template and has been fixed in both the latest beta template as well as the GA template delivered in 6.0.6. That said, you can easily fix the problem yourself by removing (deleting) the system queries that are named with the [Process Exception] prefix.
There are no other significant changes in the GA versions of the templates so you can continue to use the beta templates as you wish.
Amy

Comments
Norman Dignard commented Sep 24 '18, 9:39 a.m.

I've searched the safe 4.5 (beta) project process and I cannot find anything prefixed with [process prefix]  . Can you elaborate on what you are referring too?


Amy Silberbauer commented Sep 24 '18, 10:25 a.m. | edited Sep 30 '18, 6:02 a.m.
JAZZ DEVELOPER
Hi,
It's not [process prefix] it is [Process Exception]. Open Eclipse and then open the Project Area with the issue. Remove the [Process Exception] predefined queries. This same process can be used to remove them from the process template itself if you don't want to download the latest.

[Process Exception] Predefined Queries (Eclipse)

Please let me know if you want to meet to review this. Happy to do that.
Amy

Norman Dignard commented Sep 24 '18, 11:44 a.m.

 My apologies for the confusion. I've found the 4 queries .  I've first removed the "[process exception]" from the name , saved and tried accessing shared queries using the web ui .I then removed these 4 queries and tried again using the web ui. In both attempts I get "Error fetching queries. Array index out of range: 0" .  I then noticed in Eclispe that the [process exception] queries where still listed in the links tab of the process. I deleted the 4 links but got the same error in the web ui in accessing the predefined queries.  The web ui only shows "loading" . The 40 or so predefined queries are accessible in the Eclipse ui and I did run a few without issue.  This problem appears to be limited to the web ui.  


Amy Silberbauer commented Sep 24 '18, 12:00 p.m. | edited Sep 30 '18, 6:02 a.m.
JAZZ DEVELOPER
Hi Norman,
I think it would be best if we meet so I can take a look at this with you. Please reach out to me directly: asilber@us.ibm.com.
After we do this, I can document the specific situation here as an answer to the questions in this post.
Amy

Your answer


Register or to post your answer.