It's all about the answers!

Ask a question

CQ->RTC Synchronizer Not Synchronizing Work Items, no errors?

Amanda Whitfield (112) | asked Apr 25 '18, 3:54 p.m.
edited Apr 25 '18, 4:27 p.m.

We had an existing working CQ->RTC one-way synchronization. CQ and RTC servers were upgraded but we were able to verify that the synchronization was still working after.  Since we are changing our process, the sync rule needs to be totally overhauled.  I exported out the original rule and for starters, created a simple new sync rule for a different RTC work item type.  Also updated the CQ Synchronization Filter query in ClearQuest with a test set of records to be synched with the new rule.  Tried to delete the old sync rule and it would not delete - would get 25% of the way through and hang, only to freeze upon cancellation.  Since these changes, nothing is synchronizing, and there are no errors present in client or tomcat logs.  I've tried stopping and restarting the Apache service and always reset the gateway when updating the sync rule. CQ Status page is reporting as it should but with 300 change events not processed under Polling Information.  Every troubleshooting guide I run, everything checks out. Because of these difficulties, we even imported back in the old sync rule and narrowed it down to only the required mappings but still no luck. 

CQ version is 8.0.1
RTC Jazz Server version is 6.0.2
RTC Client version I'm using for sync rules is 5.0.2

Does anyone know what could be going on? I've been wracking my brain!! Thanks so much for helping!

On another note...ever since the upgrade, the previously working Synchronizer setup wizard page will not come up - w2k8sql1:8081/cqconnector/gateway/cqsetup only produces an error in json - "The request does not include a value for the required parameter operation"  

Could this be related?

Be the first one to answer this question!

Register or to post your answer.