It's all about the answers!

Ask a question

Why is RQMExecution tool giving errors when using password file?


anup Gaur (1392444) | asked Feb 20 '18, 10:31 p.m.
edited Feb 20 '18, 10:33 p.m.

 We are using CLM 6.0.1 on Windows. I have java 1.8.0.144 in my path. We are posting the results of an external execution in RQM using RQMExecutiontool.

Things are working fine when we are using username and password. But the command fails when using the               "-passwordFile" option. Note in the given output below the command is automatically parsing the path to present working directory. I have tried absolute path both with forward and backward slashes, but the error is same.
Below is the sample output. First command with -password option is successful, second command -passwordFile fails.

C:\RQM\RQM-Extras-ExecutionTool-6.0.1>java -jar RQMExecutionTool.jar -tcerId=204 -user=anup -password=XXXXX -publicURI="https://rqmserver.com:9443/qm" -projectName="MyProject(Quality Management)" -resultState=com.ibm.rqm.execution.common.state.passed
.
.
.
Starting execution
Execution Completed without actually executing the test

C:\RQM\RQM-Extras-ExecutionTool-6.0.1>java -jar RQMExecutionTool.jar -tcerId=204 -user=anup -passwordFile=pwd.xml -publicURI="https://rqmserver.com:9443/qm" -projectName="MyProject(Quality Management)" -resultState=com.ibm.rqm.execution.common.state.passed
Procesing Command Line arguments for Test Execution
Using passwordFile: C:\RQM\RQM-Extras-ExecutionTool-6.0.1\pwd.xml
Exception in thread "main" java.lang.IllegalArgumentException: Problems processi
ng password file
        at com.ibm.rqm.executiontool.internal.ExecutionCommandProcessor.<init>(U
nknown Source)
        at com.ibm.rqm.executiontool.ExecutionUtility.executeCommands(Unknown So
urce)
        at com.ibm.rqm.executiontool.ExecutionUtility.main(Unknown Source)


Any pointers will be helpful.


Comments
Donald Nong commented Feb 20 '18, 10:34 p.m.

What's the content of the pwd.xml file and how did it get generated?


anup Gaur commented Feb 20 '18, 10:44 p.m.

 Sorry Donald, Forgot to mention that in my question.

I have used the jbe to create the password file as mentioned in the wiki. By the way the pwd files created by jbe, is something that i have been using in build engines successfully. Below is the wiki that I used.

2 answers



permanent link
Subhajit Bhuiya (6222) | answered Feb 22 '18, 8:19 a.m.
JAZZ DEVELOPER

There is an existing defect for 6.0.1 RQM Execution Tool V6.0.1 is unable to read password file from jbe 6.0.1 (149301). This is fixed in 6.0.3. Please try with 6.0.3


permanent link
anup Gaur (1392444) | answered Feb 22 '18, 11:28 p.m.

 Hi Subhajit,


based on the Defect you have mentioned, I did try with 6.0.5 version and got the same error.
The solution was to use the RTC build toolkit 5.0.2 to generate the password file. This password file is usable and has no errors with RQM execution tool 6.0.1.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.