It's all about the answers!

Ask a question

Why can't I complete RTC New Build Definitions.


1
1
Bob Ferguson (89530) | asked Aug 14 '17, 10:55 a.m.

I am using RTC 6.0.3 and I am trying to create a new build definition.  We have not tried this before.

I select File->New->Other from the eclipse client.  I then select Team->Build Definition.  Then I select an existing repository.

I select to Create a new build definition, create a new build definition, I then select a project area.

I then give it an ID, highlight Command Line - Jazz Build Engine, I hit next for Pre-Build and Post-Build (I tried with selections for pre and post build and without).

When I get to the Additional Configuration screen, I do not have the ability to select Next or Finish.  I have tried multiple selection scenarios and the Next and Finish Buttons do not highlight.

Note:  I do have the RTC BuildSystem toolkit installed and started a Build Engine.

I do not know where to go from here.

Accepted answer


permanent link
Ulf Arne Bister (1.3k112) | answered Aug 15 '17, 8:14 a.m.

Interesting bug in the UI over which you stumbled.

As a matter of fact, most people use a different route in the UI which works. Maybe this path has not been tested.

Recipe:
Connect to project area in Eclipse, open project area tree and right-click the "Builds" folder icon. Choose "New Build Definition" from there, do as before and you will arrive at the last screen with enabled "Finish" button. I suggest to create a jazz.net defect for the UI path you used originally because by the rule of least surprise that should work, too.

If this helps for your topic please mark the answer as accepted.

- Arne

Bob Ferguson selected this answer as the correct answer

Your answer


Register or to post your answer.