It's all about the answers!

Ask a question

Getting 500Server error with OSLC since 6.0.3-Rational-CLM-ifix006


Sascha Gebhardt (1715) | asked Aug 09 '17, 5:05 a.m.
edited Aug 09 '17, 5:09 a.m.

Hello all,

i created a little tool using the OSLC interface to get information about builds in the RQM. I followed the link to the Build definition to get the needed informations with OSLC. Everything worked fine.

After the update " 6.0.3-Rational-CLM-ifix006" i receive following error:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<?xml-stylesheet type="text/xsl" href="https://MYSERVER/qm/web/com.ibm.rqm.oslc.web/ui/internal/style/ErrorStyle.xsl"?>
<rdf:RDF xmlns:calm="http://jazz.net/xmlns/prod/jazz/calm/1.0/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rqm_qm="http://jazz.net/ns/qm/rqm#" xmlns:ns9="http://jazz.net/xmlns/prod/jazz/process/1.0/" xmlns:oslc="http://open-services.net/ns/core#" xmlns:oslc_qm="http://open-services.net/ns/qm#" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:ns6="http://open-services.net/xmlns/qm/1.0/" xmlns:ns10="http://open-services.net/xmlns/discovery/1.0/" xmlns:ns11="http://jazz.net/xmlns/prod/jazz/presentation/1.0/" xmlns:dcterms="http://purl.org/dc/terms/">   
<oslc:Error ns12:type="oslc:Error" xmlns:ns12="http://www.w3.org/2001/XMLSchema-instance">        <oslc:statusCode>500</oslc:statusCode>       
<oslc:message>AQXCM5011E A server error occurred while running the HTTP operation, GET, at this URL: https://MYSERVER/qm/rqm_build/contexts/_VpoksBXnEeayuddYD89kbA/resources/com.ibm.rqm.buildintegration.BuildRecord/_aFkL4b1IEeazLrx5ndExJg. The response code is 500. </oslc:message>
<oslc:extendedError<oslc:ExtendedError>
<oslc:moreInfo rdf:resource="https://MYSERVER/clmhelp/topic/com.ibm.messages.CLMic/AQXCM5011E.html"/>
<oslc:rel>alternate</oslc:rel>
</oslc:ExtendedError>
</oslc:extendedError>       
<rqm_qm:clientLocale>de</rqm_qm:clientLocale>   
</oslc:Error></rdf:RDF>    

Has anybody an idea?

Best Regards
Sascha















Comments
Donald Nong commented Aug 10 '17, 5:58 a.m.

It only mentions an HTTP 500 code. You need to check the qm.log file for more details.

One answer



permanent link
Paul Slauenwhite (8.3k12) | answered Aug 16 '17, 10:55 a.m.
FORUM MODERATOR / JAZZ DEVELOPER

Sascha, can you please oopen a RQM defect with the details of your scenario and your RQM logs?  Whenever a RQM plublic API returns 500, we need to investigate.

Note, we're building a new OSLC QM API for build definitions/records in RQM 6.0.5 (see Improved LQE reporting - Build record, category improvements (163160)).

Your answer


Register or to post your answer.