It's all about the answers!

Ask a question

Unable to deliver using lscm - "Unable to resolve change set"


Phillip Viana (114) | asked Jul 11 '17, 7:19 p.m.

I am trying to use the lscm to promote change sets from my dev stream (i.e. from a dev stream workspace) to my test stream. Here's what I'm getting:


[me@buildvm02 logs]$ lscm deliver -c 1802 -v -r https://mycompany.com:9443/jazz/ -u build@mycompany.com -P passw0rd -t "Dev Stream Workspace" -s "Test Stream"

Unresolved change sets: 1802 Problem running 'deliver': Unable to resolve change sets.

(for the record, I tried both with aliases like 1802 above and with the change sets' UUIDs starting with underscores)

With very few exceptions, the command always fails.

I tried running lscm in verbose mode and looking at the documentation but nothing really helped. To be fair, I don't even know what an "Unresolved change set" means. It doesn't mean that the change set can't be found, since I simulated the command with bogus change set ids and I get a proper error message saying the change set doesn't exist.

Has anyone seen this before?


Comments
Shashikant Padur commented Jul 11 '17, 11:23 p.m.
JAZZ DEVELOPER

Philip,

Could you post the output of the "show status" command?

Be the first one to answer this question!


Register or to post your answer.