It's all about the answers!

Ask a question

Regarding RTC4 Plugin Preconditions

Princi Verma (28120) | asked Jun 30 '17, 2:23 a.m.


I have created one plugin, when I am running this plugin in jetty server on my local then its preconditions is visible but after deploying it on server, its preconditions is not visible.

I have tried after recreating the plugin and its deployables but same issue persists, please provide some suggestions.

Thanks and Regards,
Princi Verma

One answer

permanent link
Luca Martinucci (1.0k291110) | answered Jun 30 '17, 8:09 a.m.

It is likely that the plugin has not been deployed at all on the server.
Did you request the server reset before restarting the server?
To verify which plugins have been deployed upon restart, load the page:


and search for you plugin.

Princi Verma commented Jul 03 '17, 8:45 a.m. | edited Jul 03 '17, 8:49 a.m.

 Hi Luan,

Yes I tried after reset and then restarting the server, still precondition is not visible.
And I also checked the plugin using the above URL which you have sent, I found there plugin feature and update-site name without any error. Generated logs are mentioned below -

CRJAZ0303I The profile install from "file:ccm/sites/particular_state_wi-update-site" was started at "Mon Jul 03 13:46:22 CEST 2017".

CRJAZ0300I This feature is being installed: "net.atos.ssc.particular.state.change.feature_1.0.0.201707031233"

CRJAZ0303I The profile install from "file:ccm/sites/state_transition-update-site" was started at "Mon Jul 03 13:46:22 CEST 2017". 

Please provide some solution.I have deployed another two plugins after following the same steps, and those are working fine. I am not getting the problem exist with this. 
Thanks !


Luca Martinucci commented Jul 04 '17, 7:09 a.m.

Did you find any reference to your plugin in the provision status page?
Near the bottom, you should read something like "starting bundle <plugin id>".
Anyway, I suggest you to open a PMR.

Your answer

Register or to post your answer.