It's all about the answers!

Ask a question

problem in creating connection with jenkins from RTC


Pavitra Chitikela (1519) | asked Jun 28 '17, 5:45 a.m.

Hi,

I am trying to create build definition in RTC for Hudson/Jenkins server. In this process, I tried to create Hudson/Jenkins build engine. In Hudson/Jenkins tab I have given all the details and tried for “Test Connection”. I am getting the error as “Test connection failed”.

“Connection Test Requested.

 Connecting to:https:// apsgsgpvm21:8080/

Exception: java.net.UnknownHostException: apsgsgpvm21

Test Connection FAILED!”

Can anyone suggest how to resolve this error and to make a connection with Jenkins.

 

Regards,

Pavitra

One answer



permanent link
Arun K Sriramaiah (3.2k12263) | answered Jun 28 '17, 6:08 a.m.
edited Jun 28 '17, 6:11 a.m.

Hi Pavitra,

1) Check the hostname is accessing from the browser, before trying from the RTC   
   client.
   https:// apsgsgpvm21:8080/

2) Check the firewall settings

  If RTC server is outside a firewall it will not <g class="gr_ gr_28 gr-alert gr_gramm gr_inline_cards gr_run_anim Style multiReplace" data-gr-id="28" id="28"> reach </g> <g class="gr_ gr_28 gr-alert gr_gramm gr_inline_cards gr_disable_anim_appear Style multiReplace" data-gr-id="28" id="28"> the </g> hudson/jenkins server.

3) Did you configured with https or http?

4) Could you please try and see <g class="gr_ gr_19 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="19" id="19"> http </g>

  http :// apsgsgpvm21:8080/

Regards,
Arun.


Comments
Kunal N commented Nov 14 '19, 4:18 a.m.

 Hi Arun,


I am facing same above issue. I am able to access Jenkins url from my browser however when i try to connect using the url in RTC client i get error message as Exception: java.net.UnknownHostException:"

Is there any solution for this,


Thanks,
Kunal

Your answer


Register or to post your answer.